POJ1330 Nearest Common Ancestors【LCA+树】

Nearest Common Ancestors
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 40900 Accepted: 20173

Description

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below:
在这里插入图片描述

In the figure, each node is labeled with an integer from {1, 2,…,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is.

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y.

Write a program that finds the nearest common ancestor of two distinct nodes in a tree.

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,…, N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.
Output

Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

Sample Input

2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5

Sample Output

4
3

Source
Taejon 2002

问题链接POJ1330 Nearest Common Ancestors
问题简述:给定一颗树计算指定2个结点的最近公共祖先(LCA)。
问题分析
    标准模板题,可以用DFS来实现。因为给定的是一颗树,所以每个结点都只有一个父结点,用DFS解决时的程序代码就简单多了,一个循环即可。
    LCA问题也可以采用Tarjan算法来解决。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* POJ1330 Nearest Common Ancestors */

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

const int N = 10000;
int f[N], vis[N];

int main()
{
    int t, n, u, v;
    scanf("%d", &t);
    while(t--) {
        memset(f, -1, sizeof(f));
        memset(vis, 0, sizeof(vis));

        scanf("%d", &n);
        for(int i = 1; i < n; i++) {
            scanf("%d%d", &u, &v);
            f[v] = u;       // v的父结点是u,类似并查集
        }
        scanf("%d%d", &u, &v);

        // 先找v的所有父结点,并进行标记
        while(v != -1) {
            vis[v] = 1;
            v = f[v];       // 找父结点,找到为止
        }
        // 再找u的父结点,只找到v的父结点为止
        while(vis[u] == 0)
            u = f[u];       // 找父结点,找到为止

        printf("%d\n", u);
    }

    return 0;
}
发布了2289 篇原创文章 · 获赞 2373 · 访问量 265万+

猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/105473369
今日推荐