CF980E The Number Games【树链剖分/线段树】

CF980E The Number Games

题意翻译

Panel 国将举办名为数字游戏的年度表演。每个省派出一名选手。

国家有 n 个编号从 1 到 n 的省,每个省刚好有一条路径将其与其他省相连。第 i 个省出来的代表有 2i 名粉丝。

今年,主席打算削减开支,他想要踢掉 k 个选手。但是,被踢掉的选手的省将很 angry 并且不会让别的任何人从这个省经过。

主席想确保所有剩下选手的省都互相可达,他也希望最大化参与表演的选手的粉丝数。

主席该踢掉哪些选手呢?

输入格式

输入n,k 。( k<n106 )

下来是 n1 行,一行两个数,代表一条道路的起终点。

输出格式

升序输出要踢掉的选手编号。

感谢@poorpool 提供的翻译

题目描述

The nation of Panel holds an annual show called The Number Games, where each district in the nation will be represented by one contestant.

The nation has nn districts numbered from 11 to nn , each district has exactly one path connecting it to every other district. The number of fans of a contestant from district ii is equal to 2^i2i .

This year, the president decided to reduce the costs. He wants to remove kk contestants from the games. However, the districts of the removed contestants will be furious and will not allow anyone to cross through their districts.

The president wants to ensure that all remaining contestants are from districts that can be reached from one another. He also wishes to maximize the total number of fans of the participating contestants.

Which contestants should the president remove?

输入输出格式

输入格式:

 

The first line of input contains two integers n and k ( 1k<n106 ) — the number of districts in Panel, and the number of contestants the president wishes to remove, respectively.

The next n1 lines each contains two integers aa and b ( 1a,bn , ab ), that describe a road that connects two different districts a and b in the nation. It is guaranteed that there is exactly one path between every two districts.

 

输出格式:

 

Print k space-separated integers: the numbers of the districts of which the contestants should be removed, in increasing order of district number.

输入输出样例

输入样例#1: 复制
6 3
2 1
2 6
4 2
5 6
2 3
输出样例#1: 复制
1 3 4
输入样例#2: 复制
8 4
2 6
2 7
7 8
1 2
3 1
2 4
7 5
输出样例#2: 复制
1 3 4 5

说明

In the first sample, the maximum possible total number of fans is 2^2 + 2^5 + 2^6 = 100 . We can achieve it by removing the contestants of the districts 1, 3, and 4.


Solution

哭,写完才发现为什么别人的代码那么短QAQ

暴拍了个树剖+线段树修改QAQ

思路也就是贪心了,把$n$定为根节点,从大往小选,要选它选意味着这个点到根节点的点全都要选,所以每次计算这条路上可以选的数量,能选就选,然后修改线段树,最后查询线段树上没有被修改的就行了。

Code

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int n, k;

struct Node {
    int u, v, nex;
    Node(int u = 0, int v = 0, int nex = 0) :
        u(u), v(v), nex(nex) { }
} Edge[2000005];

int h[1000005], stot;
void add(int u, int v) {
    Edge[++stot] = Node(u, v, h[u]);
    h[u] = stot;
}

int fa[1000005], siz[1000005], son[1000005];
void dfs1(int u, int f) {
    fa[u] = f;    siz[u] = 1;
    for(int i = h[u]; i; i = Edge[i].nex) {
        int v = Edge[i].v;
        if(v == f)    continue;
        dfs1(v, u);
        siz[u] += siz[v];
        if(siz[v] > siz[son[u]])    son[u] = v;
    }
}

int top[1000005], in[1000005], idc;
void dfs2(int u, int t) {
    top[u] = t;    in[u] = ++idc;
    if(son[u])    dfs2(son[u], t);
    for(int i = h[u]; i; i = Edge[i].nex) {
        int v = Edge[i].v;
        if(v == fa[u] || v == son[u])    continue;
        dfs2(v, v);
    }
}

int TR[4000005], tag[4000005];
void update(int nd) {
    TR[nd] = TR[nd << 1] + TR[nd << 1 | 1];
}

void push_down(int nd, int l, int r) {
    if(~tag[nd]) {
        int mid = (l + r) >> 1;
        TR[nd << 1] = 0;
        TR[nd << 1 | 1] = 0;
        tag[nd << 1] = 0; tag[nd << 1 | 1] = 0;
        tag[nd] = -1;
    }
}

void build(int nd, int l, int r) {
    tag[nd] = -1;
    if(l == r) {
        TR[nd] = 1;
        return ;
    }
    int mid = (l + r) >> 1;
    build(nd << 1, l, mid);
    build(nd << 1 | 1, mid + 1, r);
    update(nd);
}

int query(int nd, int l, int r, int L, int R) {
    if(l >= L && r <= R)    return TR[nd];
    push_down(nd, l, r);
    int ans = 0; int mid = (l + r) >> 1;
    if(L <= mid)    ans += query(nd << 1, l, mid, L, R);
    if(R > mid)        ans += query(nd << 1 | 1, mid + 1, r, L, R);
    return ans;
}

void modify(int nd, int l, int r, int L, int R) {
    if(l >= L && r <= R) {
        TR[nd] = 0;
        tag[nd] = 0;
        return ;
    }
    push_down(nd, l, r);
    int mid = (l + r) >> 1;
    if(L <= mid)    modify(nd << 1, l, mid, L, R);
    if(R > mid)        modify(nd << 1 | 1, mid + 1, r, L, R);
    update(nd);
}

int query(int u) {
    int ans = 0;
    while(top[u] != 0) {
        ans += query(1, 1, n, in[top[u]], in[u]);
        u = fa[top[u]];
    }
    ans += query(1, 1, n, in[n], in[u]);
    return ans;
}

void modify(int u) {
    while(top[u] != 0) {
        modify(1, 1, n, in[top[u]], in[u]);
        u = fa[top[u]];
    }
    modify(1, 1, n, in[n], in[u]);
}

int use[1000005];
int main() {
    scanf("%d%d", &n, &k);
    memset(use, 1, sizeof(use));
    for(int i = 1; i < n; i ++) {
        int u, v;
        scanf("%d%d", &u, &v);
        add(u, v); add(v, u);
    }
    dfs1(n, 0); dfs2(n, 0);
    build(1, 1, n);
    int tot = n - k;
    for(int i = n; i >= 1 && tot; i --) {
        int tmp = query(i);
        if(tmp <= tot) {
            tot -= tmp;
            modify(i);
        }
    }
    for(int i = 1; i <= n; i ++)
        if(query(1, 1, n, in[i], in[i]))    printf("%d ", i);
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/wans-caesar-02111007/p/9811363.html
今日推荐