K - Transformation HDU - 4578(线段树)

Yuanfang is puzzled with the question below:
There are n integers, a 1, a 2, …, a n. The initial values of them are 0. There are four kinds of operations.
Operation 1: Add c to each number between a x and a y inclusive. In other words, do transformation a k<---a k+c, k = x,x+1,…,y.
Operation 2: Multiply c to each number between a x and a y inclusive. In other words, do transformation a k<---a k×c, k = x,x+1,…,y.
Operation 3: Change the numbers between a x and a y to c, inclusive. In other words, do transformation a k<---c, k = x,x+1,…,y.
Operation 4: Get the sum of p power among the numbers between a x and a y inclusive. In other words, get the result of a x p+a x+1 p+…+a y p.
Yuanfang has no idea of how to do it. So he wants to ask you to help him.

Input

There are no more than 10 test cases.
For each case, the first line contains two numbers n and m, meaning that there are n integers and m operations. 1 <= n, m <= 100,000.
Each the following m lines contains an operation. Operation 1 to 3 is in this format: "1 x y c" or "2 x y c" or "3 x y c". Operation 4 is in this format: "4 x y p". (1 <= x <= y <= n, 1 <= c <= 10,000, 1 <= p <= 3)
The input ends with 0 0.

Output

For each operation 4, output a single integer in one line representing the result. The answer may be quite large. You just need to calculate the remainder of the answer when divided by 10007.

Sample Input

5 5
3 3 5 7
1 2 4 4
4 1 5 2
2 2 5 8
4 3 5 3
0 0

Sample Output

307
7489

解题思路:

硬来肯定是不行的,尽管人家给了8000ms。。刚开始初始值都是一样的,经过一项操作之后该区间的数值也是一样的,这里就是突破点。查询的时候肯定不能一个一个点算,但是如果某一区间的数值都相同的话,那该区间的和就是x^p * (r - l + 1)了(x为单点的数值,(r - l + 1)为区间长度,如此一来就能节约很多时间。当然,线段树中的节点存放的就是该区间的单点的数值(如果该区间所有的数值都相同的话)。具体请看下面代码。

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

const int mod = 10007;
const int maxn = 100020;
int n, m;
int Tree[maxn << 2];
bool flag[maxn << 2];

void Init()
{
	memset(flag, true, sizeof(flag));
	memset(Tree, 0, sizeof(Tree));
}

void update(int op, int L, int R, int val, int l, int r, int rt)
{
	if(l >= L && r <= R && flag[rt])
	{
		if(op == 1)
			Tree[rt] = (Tree[rt] + val) % mod;
		else if(op == 2)
			Tree[rt] = (Tree[rt] * val) % mod;
		else if(op == 3)
			Tree[rt] = val;
		return ;
	}
	if(flag[rt])
	{
		flag[rt << 1] = flag[rt << 1 | 1] = 1;
		flag[rt] = false;
		Tree[rt << 1] = Tree[rt << 1 | 1] = Tree[rt];
	}
	int m = (l + r) / 2;
	if(m >= L)
		update(op, L, R, val, l, m, rt << 1);
	if(m < R)
		update(op, L, R, val, m + 1, r, rt << 1 | 1);
	if(!flag[rt << 1] || !flag[rt << 1 | 1])
		flag[rt] = false;
	else
	{
		if(Tree[rt << 1] != Tree[rt << 1 | 1])
			flag[rt] = false;
		else 
		{
			flag[rt] = true;
			Tree[rt] = Tree[rt << 1];
		}
	}
}

int query(int L, int R, int p, int l, int r, int rt)
{
	if(l >= L && r <= R && flag[rt])
	{
		int ans = 1;
		for(int i = 1; i <= p; ++ i)
		{
			ans = (ans * Tree[rt]) % mod;
		}
		ans = ans * (r - l + 1) % mod;
		return ans;
	}
    if(flag[rt])
	{
		flag[rt<<1]=flag[rt<<1|1]=1; 
		flag[rt]=0; 
		Tree[rt<<1]=Tree[rt<<1|1]=Tree[rt]; 
	}
	int m = (l + r) / 2;
	int ans = 0;
	if(m >= L)
		ans += query(L, R, p, l, m, rt << 1);
	if(m < R)
		ans += query(L, R, p, m + 1, r, rt << 1 | 1);
	return ans % mod;
}

int main()
{
	while(cin >> n >> m)
	{
		if(n == 0 && m == 0)
			break;
		int x, y, op, num;
		Init();
		for(int i = 1; i <= m; ++ i)
		{
			scanf("%d%d%d%d", &op, &x, &y, &num);
			if(op <= 3)
			{
				update(op, x, y, num, 1, n, 1);
			}
			else
			{
				printf("%d\n", query(x, y, num, 1, n, 1));
			}
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/aqa2037299560/article/details/82829080