K - Transformation HDU - 4578(线段树)

Yuanfang is puzzled with the question below:
There are n integers, a 1, a 2, …, a n. The initial values of them are 0. There are four kinds of operations.
Operation 1: Add c to each number between a x and a y inclusive. In other words, do transformation a k<---a k+c, k = x,x+1,…,y.
Operation 2: Multiply c to each number between a x and a y inclusive. In other words, do transformation a k<---a k×c, k = x,x+1,…,y.
Operation 3: Change the numbers between a x and a y to c, inclusive. In other words, do transformation a k<---c, k = x,x+1,…,y.
Operation 4: Get the sum of p power among the numbers between a x and a y inclusive. In other words, get the result of a x p+a x+1 p+…+a y p.
Yuanfang has no idea of how to do it. So he wants to ask you to help him.

Input

There are no more than 10 test cases.
For each case, the first line contains two numbers n and m, meaning that there are n integers and m operations. 1 <= n, m <= 100,000.
Each the following m lines contains an operation. Operation 1 to 3 is in this format: "1 x y c" or "2 x y c" or "3 x y c". Operation 4 is in this format: "4 x y p". (1 <= x <= y <= n, 1 <= c <= 10,000, 1 <= p <= 3)
The input ends with 0 0.

Output

For each operation 4, output a single integer in one line representing the result. The answer may be quite large. You just need to calculate the remainder of the answer when divided by 10007.

Sample Input

5 5
3 3 5 7
1 2 4 4
4 1 5 2
2 2 5 8
4 3 5 3
0 0

Sample Output

307
7489

解题思路:

线段树的各种操作都是很简单的,这道题的突破点就在于判断区间的所有数是否相同,如果相同的话求他们的幂就很简单了,也就是求出其中一个再乘上区间长度就好了。flag数组判断是否为相同的数,Tree数组存放相同的数的数值

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

const int mod = 10007;
const int maxn = 100020;
int n, m;
int Tree[maxn << 2];
bool flag[maxn << 2];

void Init()
{
	memset(flag, true, sizeof(flag));
	memset(Tree, 0, sizeof(Tree));
}

void update(int op, int L, int R, int val, int l, int r, int rt)
{
	if(l >= L && r <= R && flag[rt])
	{
		if(op == 1)
			Tree[rt] = (Tree[rt] + val) % mod;
		else if(op == 2)
			Tree[rt] = (Tree[rt] * val) % mod;
		else if(op == 3)
			Tree[rt] = val;
		return ;
	}
	if(flag[rt])
	{
		flag[rt << 1] = flag[rt << 1 | 1] = 1;
		flag[rt] = false;
		Tree[rt << 1] = Tree[rt << 1 | 1] = Tree[rt];
	}
	int m = (l + r) / 2;
	if(m >= L)
		update(op, L, R, val, l, m, rt << 1);
	if(m < R)
		update(op, L, R, val, m + 1, r, rt << 1 | 1);
	if(!flag[rt << 1] || !flag[rt << 1 | 1])
		flag[rt] = false;
	else
	{
		if(Tree[rt << 1] != Tree[rt << 1 | 1])
			flag[rt] = false;
		else 
		{
			flag[rt] = true;
			Tree[rt] = Tree[rt << 1];
		}
	}
}

int query(int L, int R, int p, int l, int r, int rt)
{
	if(l >= L && r <= R && flag[rt])
	{
		int ans = 1;
		for(int i = 1; i <= p; ++ i)
		{
			ans = (ans * Tree[rt]) % mod;
		}
		ans = ans * (r - l + 1) % mod;
		return ans;
	}
    if(flag[rt])
	{
		flag[rt<<1]=flag[rt<<1|1]=1; 
		flag[rt]=0; 
		Tree[rt<<1]=Tree[rt<<1|1]=Tree[rt]; 
	}
	int m = (l + r) / 2;
	int ans = 0;
	if(m >= L)
		ans += query(L, R, p, l, m, rt << 1);
	if(m < R)
		ans += query(L, R, p, m + 1, r, rt << 1 | 1);
	return ans % mod;
}

int main()
{
	while(cin >> n >> m)
	{
		if(n == 0 && m == 0)
			break;
		int x, y, op, num;
		Init();
		for(int i = 1; i <= m; ++ i)
		{
			scanf("%d%d%d%d", &op, &x, &y, &num);
			if(op <= 3)
			{
				update(op, x, y, num, 1, n, 1);
			}
			else
			{
				printf("%d\n", query(x, y, num, 1, n, 1));
			}
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/aqa2037299560/article/details/82872866