P - Atlantis HDU - 1542(矩形面积并 + 线段树离散化优化)

There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.
Input
The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1<x2<=100000;0<=y1<y2<=100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.

The input file is terminated by a line containing a single 0. Don’t process it.
Output
For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.

Output a blank line after each test case.
Sample Input
2
10 10 20 20
15 15 25 25.5
0
Sample Output
Test case #1
Total explored area: 180.00

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int maxn = 500;
int n;
double all[maxn];
double tree[maxn * 2];
int lazy[maxn * 2];
struct Rec
{
	double l, r;
	double h;
	int d;
	Rec(){}
	Rec(double t1, double t2, double t3, int t4)
	{
		l = t1;
        r = t2;
        h = t3;
        d = t4;
	}
	friend bool operator < (Rec a, Rec b)
	{
		return a.h < b.h;
	}



}a[maxn], temp;


void push_up(int l, int r, int rt)
{
	if(lazy[rt])
		tree[rt] = all[r + 1] - all[l];
	else if(l == r)
		tree[rt] = 0;
	else
		tree[rt] = tree[rt << 1] + tree[rt << 1 | 1];
}

void update(int L, int R, int val, int l, int r, int rt)
{
	if(l >= L && r <= R)
	{
		lazy[rt] += val;
		push_up(l, r, rt);
		return ;
	}
	int m = (l + r) / 2;
	if(m >= L)
		update(L, R, val, l, m, rt << 1);
	if(m < R)
		update(L, R, val, m + 1, r, rt << 1 | 1);
	push_up(l, r, rt);
}


int main()
{
    //freopen("in.txt", "r", stdin);
    int kcase = 1;
	while(cin >> n)
	{
		if(n == 0)
			break;
		double x1, x2, y2, y1;
		for(int i = 1; i <= n; ++ i)
		{
			scanf("%lf%lf%lf%lf", &x1, &y1, &x2, &y2);
			all[i] = x1, all[i + n] = x2;

			a[i] = Rec(x1, x2, y1, 1);
			a[i + n] = Rec(x1, x2, y2, -1);
		}
		n <<= 1;
		int sum;
		sort(all + 1, all + 1 + n);
		sum = unique(all + 1, all+ 1 + n) - all - 1;

		sort(a + 1, a + 1 + n);

		double ans = 0;
		memset(tree, 0, sizeof(tree));
		memset(lazy, 0, sizeof(lazy));
		for(int i = 1; i < n; ++ i)
		{
			int l = lower_bound(all + 1, all + 1 + sum, a[i].l) - all;
			int r = lower_bound(all + 1, all + 1 + sum, a[i].r) - all;
            if(l < r)
                update(l, r - 1, a[i].d, 1, sum, 1);
			ans += tree[1] * (a[i + 1].h - a[i].h);
		}
		printf("Test case #%d\nTotal explored area: %.2lf\n\n", kcase++, ans);
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/aqa2037299560/article/details/82952270
今日推荐