[HDU] 1542 - Atlantis - 矩形并 - 离散化 - 扫描线 - 线段树

Atlantis

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15215    Accepted Submission(s): 6258


Problem Description
There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.
 

Input
The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1<x2<=100000;0<=y1<y2<=100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.

The input file is terminated by a line containing a single 0. Don’t process it.
 

Output
For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.

Output a blank line after each test case.
 

Sample Input
 
  
2 10 10 20 20 15 15 25 25.5 0
 

Sample Output
 
  
Test case #1 Total explored area: 180.00
 

Source
 

Recommend
linle


感觉其实自己还是有一些不太明白的。。。


矩形并的模板题     目前还在思考除了题解还要不要写教程= =


PPT没法上传特别气人= =!


#include <cstdio>
#include <vector>
#include <algorithm>
#define pb push_back
#define mp make_pair
#define LL long long
using namespace std;

const int N = 11000;

struct Line
{
    double h;
    int l;
    int r;
    int mark;
};

struct Node
{
    double x1, x2;
    double y1, y2;
};

struct Tree
{
    int l;
    int r;
    int cnt;
    double len;
};

vector<double> id;
Line line[N * 4];
Tree tree[N * 4];
Node node[N * 4];
int n;

int get_id(double x)
{
    return lower_bound(id.begin(), id.end(), x) - id.begin() + 1;
}

bool cmp(Line a, Line b)
{
    if(a.h == b.h){
        if(a.l == b.l){
            return a.r < b.r;
        }
        else{
            return a.l > b.l;
        }
    }
    else{
        return a.h < b.h;
    }
}

void up(int x)
{
    if(tree[x].cnt){
        tree[x].len = id[tree[x].r] - id[tree[x].l - 1];
    }
    else{
        tree[x].len = tree[x << 1].len + tree[x << 1 | 1].len;
    }
}

void build(int x, int l, int r)
{
    tree[x].l = l;
    tree[x].r = r;
    tree[x].cnt = 0;
    tree[x].len = 0;
    if(l == r){
        return ;
    }
    else{
        int mid;

        mid = l + ((r - l) >> 1);
        build(x << 1, l, mid);
        build(x << 1 | 1, mid + 1, r);
        up(x);
    }
}

void update(int x, int l, int r, int t)
{
    int ll = tree[x].l;
    int rr = tree[x].r;

    if(l > r){
        return ;
    }
    if(l == ll && r == rr){
        tree[x].cnt += t;
        up(x);
    }
    else{
        int mid;

        mid = ll + ((rr - ll) >> 1);
        update(x << 1, l, min(mid, r), t);
        update(x << 1 | 1, max(mid + 1, l), r, t);
        up(x);
    }
}

int main(int argc, char const *argv[])
{
    int cnt;
    int nc = 1;
    double ans;

    while(scanf("%d", &n) == 1){
        if(!n){
            break;
        }
        cnt = 1;
        ans = 0;
        for(int i = 0; i < n; i ++){
            scanf("%lf%lf%lf%lf", &node[i].x1, &node[i].y1, &node[i].x2, &node[i].y2);
            id.pb(node[i].x1);
            id.pb(node[i].x2);
        }
        sort(id.begin(), id.end());
        id.erase(unique(id.begin(), id.end()), id.end());
        build(1, 1, id.size() + 1);
        for(int i = 0; i < n; i ++){
            line[cnt].l = get_id(node[i].x1);
            line[cnt].r = get_id(node[i].x2);
            line[cnt].h = node[i].y1;
            line[cnt].mark = 1;
            cnt ++;
            line[cnt].l = get_id(node[i].x1);
            line[cnt].r = get_id(node[i].x2);
            line[cnt].h = node[i].y2;
            line[cnt].mark = -1;
            cnt ++;
        }
        sort(line + 1, line + cnt, cmp);
        line[0].h = line[1].h;
        for(int i = 1; i < cnt; i ++){
            ans += (line[i].h - line[i - 1].h) * tree[1].len;
            update(1, line[i].l, line[i].r - 1, line[i].mark);
        }
        printf("Test case #%d\n", nc ++);
        printf("Total explored area: %.2f\n\n", ans);
    }

    return 0;
}


猜你喜欢

转载自blog.csdn.net/yiranluoshen/article/details/78746957