(2)R - 贪心

Today the company has m tasks to complete. The ith task need xi minutes to complete. Meanwhile, this task has a difficulty level yi. The machine whose level below this task’s level yi cannot complete this task. If the company completes this task, they will get (500*xi+2*yi) dollars.
The company has n machines. Each machine has a maximum working time and a level. If the time for the task is more than the maximum working time of the machine, the machine can not complete this task. Each machine can only complete a task one day. Each task can only be completed by one machine.
The company hopes to maximize the number of the tasks which they can complete today. If there are multiple solutions, they hopes to make the money maximum.
Input The input contains several test cases.
The first line contains two integers N and M. N is the number of the machines.M is the number of tasks(1 < =N <= 100000,1<=M<=100000).
The following N lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the maximum time the machine can work.yi is the level of the machine.
The following M lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the time we need to complete the task.yi is the level of the task. Output For each test case, output two integers, the maximum number of the tasks which the company can complete today and the money they will get. Sample Input
1 2
100 3
100 2
100 1
Sample Output
 
 

1 50004


题意:公司有m个任务要求完成,每一个任务需要一台机器xi分钟完成,任务等级为yi,公司收益为(500*xi+yi),输入n.m表示有n,台机器,m个任务,在输入n台机器的工作时间和等级,只有这两项大于任务的,这个任务才能完成。

思路:从最大的时间任务开始,找出满足条件的等级最小的机器,
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
struct node
{
 int xi;
 int yi;
};
node mach[100010];
node taxt[100010];
bool cmp(node x,node y)
{
 if(x.xi!=y.xi)
 {
  return x.xi>y.xi;
 }
 else//时间相同时,按等级排序
 {
  return x.yi>y.yi;
 }
}
int main()
{
 int i,j,k;
 int n,m;
 while(cin>>n>>m)
 {
  long long sum=0;
  int num=0;
  int level[110]={0};
  for(i=0;i<n;i++)
  {
   cin>>mach[i].xi>>mach[i].yi;
  }
  for(i=0;i<m;i++)
  {
   cin>>taxt[i].xi>>taxt[i].yi;
  }
  sort(mach,mach+n,cmp);
  sort(taxt,taxt+m,cmp);
  j=0;
  for(i=0;i<m;i++)
  {
   while(j<n&&taxt[i].xi<=mach[j].xi)//寻找时间满足的机器
   {
    level[mach[j].yi]++;//如果满足就标记
    j++;//记录第几个机器
   }
   for(k=taxt[i].yi;k<=100;k++)
   {
    if(level[k])//如果最低等级满足
    {
     sum+=taxt[i].xi*500+taxt[i].yi*2;
     num+=1;
     level[k]--;//标记清除,不同任务等级可能相同,所以要清除
     break;  
    }
   }
  }
  cout<<num<<" "<<sum<<endl;
  
 }
}

猜你喜欢

转载自blog.csdn.net/whhhzs/article/details/79378934
今日推荐