HihoCoder - 1425 What a Beautiful Lake(水题)

版权声明:Copyright : 李三金,原创文章转载标明出处即可。 https://blog.csdn.net/santa9527/article/details/53260248

HihoCoder - 1425 What a Beautiful Lake

Weiming Lake, also named "Un-named Lake", is the most famous scenic spot in Peking University. It is located in the north of the campus and is surrounded by walking paths, small gardens, and old red buildings with typical Chinese curly roofs. The lake was once the royal garden in Qing Dynasty. Boya tower stands on a little hill beside the lake. The lake and the tower form a distinctive landscape and a symbol of Peking University.

Weiming Lake is a very good place for studying, reading, skating in the winter, and of course, jogging. More and more students and teachers run or walk aroundWeiming Lake every day and show how many paces they have covered in the mobile appWeChat Sports to get "Zans" (applauses).

ACMer X also enjoys jogging aroundWeiming Lake. His watch can measure and record an altitude value every meter. After a round of running, X collected the altitude data around the lake. Now he wants to find out the longest slope around the lake. 

Input

There are no more than 20 test cases.

Each case has two lines.

The first line is an integer N (2 <= N <= 100) meaning that the length of the road around the lake is N meters.

The second line contains N integersa1,a2...aN, (0<=a1,a2...aN <= 100) indicating N altitude sample values around the lake. The samples are given in clockwise order, and the distance between two adjacent samples is one meter. Of course the distance between a1 andaN is also one meter.

The input ends by a line of 0.

Output

For each test case, print the length of the longest slope in meters. A slope is a part of the road around the lake, and it must keep going up or going down. If there are no slope, print 0.

Sample Input

4

1 1 1 1

8

5 1 2 3 4 5 6 2

6

5 4 3 2 1 2

10

1 0 2 3 2 2 3 4 3 2

0

Sample Output

0

5

4

4

Hint

sorces: 2016年ICPC北京站(感谢北大出题)

先来一段翻译:

未名湖,也叫”无名湖”,是北大的著名景观。未名湖位于校园北部,四周环有步行道、小花园,红色的中式经典卷棚顶老建筑。此湖曾为清朝御花园。博雅塔伫立在湖边小山上。这一湖一塔即是北大独特的标志景观。
    未名湖是读书学习,冬日滑冰,以及慢跑的好去处。越来越多的师生每天绕湖或行或走,并且在手机应用微信运动上展示步数求”赞”(鼓掌)。
    ACMer X 也入坑未名湖环跑。他的手表可以测量和记录单位为米的高度。跑了一圈后,X收集了湖周围的高度数据。现在他想找出湖周围最长的斜坡。
 测试用例不超过20组。
    每个用例只有两行。
    第一行为一个整数N (2 <= N <= 100) 表示环湖道路的长度为N米。
    第二行有N个整数a1, a2 ... aN, (0 <= a1, a2 ... aN <= 100) 表示N个环绕湖的样本高度。样本按逆时针排序,两个样本间的距离为一米。当然了,a1 与 aN的间距也是一米。
    对于每个测试用例,输出最长斜坡的长度为多米。斜坡是环湖道路的一部分,必须保持上升或下降。如果没有斜坡,则输出0。

注意题目意思的要求是斜坡为严格递增或递增,有相等的两个数即会断开斜坡的计算。

也就是说,只要找出严格递增或递减的最长子序列就可以了,很简单的过程。

注意湖是环状的!!!!

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#define MAXN 1024
using namespace std;
int h[MAXN*10],a[MAXN*10];
int main()
{
    int n;
    int i,j,k;
    while(~scanf("%d",&n)&&n)
    {
        for(i=0; i<n; i++)
            scanf("%d",&h[i]),h[i+n]=h[i];//j输入数据,并将数据拼接到后端,模拟圆环
        int sum1=0,sum2=0,len=0;
        for(i=1; i<n*2; i++)
        {
            if(h[i]>h[i-1]) sum1++,len=max(sum1,len);//找出严格连续递增的子序列,顺便找最长的
            else sum1=0;
            if(h[i]<h[i-1]) sum2++,len=max(sum2,len);//找出严格连续递减的子序列,顺便找最长的
            else sum2=0;
        }
        printf("%d\n",len);
    }
}

猜你喜欢

转载自blog.csdn.net/santa9527/article/details/53260248