POJ1751 Highways(prim打印边)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_42391248/article/details/82177707

Highways

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 21195   Accepted: 6256   Special Judge

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length.

Input

The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built.

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of ith town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location.

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway.

Output

Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space.

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty.

Sample Input

9
1 5
0 0 
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2

Sample Output

1 6
3 7
4 9
5 7
8 3

题意:输出分为两部分,第一部分给出N表示一共N个点(编号1-9),下面N行表示点的坐标,第二部分给出K,下面K行每行两个编号,表示两个点相连。求这些点组成的完全图的最小生成树,输出还需要连的线。如果不需要连线,则输出为空。

题解:本题边多,所以用prim算法好点。难点在于输出边。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
using namespace std;
typedef struct {
	int x,y;
}point;
int map[752][752];
const int INF=1<<30;
int visit[752];
int eg[752];//i和eg[i]连通 
int d[752];
int main()
{
	int n;
	cin>>n;
	point a[752];
	for(int i=1;i<=n;i++)
		scanf("%d%d",&a[i].x,&a[i].y);
	//建图 
	memset(map,INF,sizeof(map));
	memset(visit,1,sizeof(visit));
	memset(d,0,sizeof(d));
	for(int i=1;i<=n-1;i++)
		for(int j=i+1;j<=n;j++)
			map[i][j]=map[j][i]=(i==j?0:((a[i].x-a[j].x)*(a[i].x-a[j].x)+(a[i].y-a[j].y)*(a[i].y-a[j].y)));	
	int k;
	cin>>k;
	for(int i=0;i<k;i++)
	{
		int p,q;
		scanf("%d%d",&p,&q);
		map[p][q]=map[q][p]=0;
	}
	//prim 
	int i,j;
	for(i=1;i<=n;i++)
		d[i]=map[i][1],eg[i]=1;
//让每个点都与1相连,下面找到和1相连的点temp,eg[temp]就是1. 
	visit[1]=0;
	for(i=1;i<=n;i++)
	{
		int max=INF;
		int temp;
		for(j=1;j<=n;j++)
			if(visit[j]&&d[j]<minn)
			{
				minn=d[j];
				temp=j;
			}
		visit[temp]=0;
		for(j=1;j<=n;j++)
			if(visit[j]&&d[j]>map[j][temp])
				d[j]=map[j][temp],eg[j]=temp;//对eg的操作作用同上 
		//输出边 
		if(map[eg[temp]][temp]&&minn!=0&&minn!=INF)
			printf("%d %d\n",eg[temp],temp);
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42391248/article/details/82177707
今日推荐