poj 1751 并查集(prim)

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length. 
Input
The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built. 

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of i  th town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location. 

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway. 
Output
Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space. 

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty. 
Sample Input
9
1 5
0 0 
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2
Sample Output
1 6
3 7
4 9
5 7
8 3
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include <string>
#include<cmath>
using namespace std;
int N=0x3f3f3f3f;
int e[1000][1000];
struct node
{
    int x;
    int y;
}num[1000];
int dis[800]={0};
int book[800]={0};
int main()
{
    int n;
    cin>>n;
    for(int i=1;i<=n;i++)
    cin>>num[i].x>>num[i].y;
    for(int i=1;i<=n;i++)
        for(int j=i+1;j<=n;j++){
        e[i][j]=e[j][i]=(num[i].x-num[j].x)*(num[i].x-num[j].x)+(num[i].y-num[j].y)*(num[i].y-num[j].y);
        if(i==j)
            e[i][j]=N;
        }
    int m;
    int pre[800];//记录前一个结点,也就是通过那个点使下一个点得到松弛,使其更靠近生成树
    cin>>m;
    for(int i=0;i<m;i++)
    {
        int x,y;
        cin>>x>>y;
        e[x][y]=e[y][x]=0;//说明x y两点已经连接,为下面每次判断最近点排除已连接的点做标记;
    }
    for(int i=1;i<=n;i++)
        dis[i]=e[1][i],book[i]=0,pre[i]=1;//开始假设都是通过1号点与树最近
        book[1]=1;//记录那些点加入到树中;
    for(int i=1;i<=n;i++)
    {
        int mi=N;
        int u;
        for(int j=1;j<=n;j++)
        {
            if(dis[j]<mi&&book[j]!=1)
            {
                u=j;
                mi=dis[j];
            }
        }
        if(e[u][pre[u]])
            cout<<u<<" "<<pre[u]<<endl;
            //dis[u]=-1;

        for(int k=1;k<=n;k++)
        {
            if(!book[k]&&e[u][k]<dis[k])
            {
                dis[k]=e[u][k];
                pre[k]=u;
            }
        }
         book[u]=1;//这一步说明该点最近,可以加入到树中;
    }
    return 0;
}
因为此题边多与点,属于稠密图,可考虑prim算法

猜你喜欢

转载自blog.csdn.net/c___c18/article/details/80386030
今日推荐