POJ 1703 Find them, Catch them

http://poj.org/problem?id=1703

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stdio.h>
using namespace std;

const int maxn = 1e5 + 10;
int n, m;
int par[maxn * 2], high[maxn * 2];

void init(int n) {
	for(int i = 1; i <= n; i++) {
		par[i] = i;
		high[i] = 0;
	}
}

int Find(int x) {
	return par[x] == x ? x : par[x] = Find(par[x]);
}

void unite(int x, int y) {
	x = Find(x);
	y = Find(y);
	if(x == y)	return;

	if(high[x] < high[y])	par[x] = y;
	else {
		par[y] = x;
		if(high[x] == high[y])	high[x]++;
	}
}

bool same(int x, int y) {
	return Find(x) == Find(y);
}

int main() {
    int T;
    scanf("%d", &T);
    while(T --) {
		scanf("%d%d", &n, &m);
		init(2 * n);
		char op;
		int a, b;
		for(int i = 1; i <= m; i ++) {
			scanf("\n%c%d%d", &op, &a, &b);
			if(op == 'D') {
				unite(a, b + n);
				unite(a + n, b);
			} else {
				if(same(a, b + n) || same(a + n, b))
                    printf("In different gangs.\n");
				else if(same(a, b) || same(a + n, b + n))
                    printf("In the same gang.\n");
				else
                    printf("Not sure yet.\n");
			}
		}
	}
    return 0;
}

  

猜你喜欢

转载自www.cnblogs.com/zlrrrr/p/9756967.html
今日推荐