Find them, Catch them——POJ 1703

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

题意:给出两个人说明他们不属于同一个队问给出两个人他们属于一个队还是不同的队或是不确定
思路:分两个区间在未确定是用n+c表示n的不同帮派,则if(find(x)==find(y+n))则他们属于不同帮派
#include <iostream>
#include <algorithm>
using namespace std;
int pre[200000];
int find(int x){
	if(pre[x]==x)
		return x;
	else 
		return pre[x]=find(pre[x]);
}
void men(int x,int y){
	int a=find(x),b=find(y);
	if(a!=b)
		pre[a]=b;
}
int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		int n,m;
		scanf("%d %d",&n,&m);
		char c;
		int x,y;
		for(int i=0;i<=2*n;i++){
			pre[i]=i;
		}
		getchar();
		for(int i=0;i<m;i++){
			scanf("%c %d %d",&c,&x,&y);
			getchar();//吸收回车 
			if(c=='A'){
				if(find(x)==find(y+n) && find(x+n)==find(y)) //一开始判断分别和另一个的反面是否在同一个帮派 
					printf("In different gangs.\n");
				else if(find(x)==find(y))//指向反面就是相同的帮派 
					printf("In the same gang.\n");
				else{
					printf("Not sure yet.\n");
				}
			}
			else{
				men(x,y+n);
				men(x+n,y);
			}
		}
	}
}


猜你喜欢

转载自blog.csdn.net/doublekillyeye/article/details/81041758
今日推荐