Find them, Catch them@POJ 1703

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

题目分析:比较基础的种类并查集。

只有两种关系:0同一队,1不同。

如果两人的直接父节点不同,只能说明两人不在同一个集合,但不能判断两人是否在一个队(因为题目中总共只有两只队伍)。

当两人父节点相同时,就判断跟父节点的关系,如果一样说明在一队,反之不在同一队。

#include <algorithm>
#include <iostream>
#include <string>
#include <vector>
#include <cstring>
#include <cstdio>
#include <stack>
#include <set>
#define MAXN 100004
using namespace std;

int f[MAXN],r[MAXN];

int getf(int a){
    if(a == f[a]) return a;
    int t = getf(f[a]);
    r[a] = (r[f[a]]+r[a])%2;
    f[a] = t;
    return t;
}

void Union(int a,int b){
    int fa = getf(a);
    int fb = getf(b);
    if(fa != fb){
        f[fb] = fa;
        r[fb] = (r[a]-r[b]+1+2)%2;
    }
}

int main(){
    int t;
    scanf("%d",&t);
    int n,m;
    while(t--){
        scanf("%d%d",&n,&m);
        getchar();
        for(int i=1;i<=n;++i){
            f[i] = i;
            r[i] = 0;
        }
        char op;
        int a,b;
        for(int i=0;i<m;++i){
            scanf("%c%d%d",&op,&a,&b);
            getchar();
            if(op == 'A'){
                if(getf(a) != getf(b)) cout << "Not sure yet." << endl;
                else{
                    if(r[a] == r[b]) cout << "In the same gang." << endl;
                    else cout << "In different gangs." << endl;
                }
            }
            else{
                Union(a,b);
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_39021458/article/details/81299265