POJ 1011 Sticks【DFS+剪枝】

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_37867156/article/details/82628062

题目链接:http://poj.org/problem?id=1011

Description

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.

Input

The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

Output

The output should contains the smallest possible length of original sticks, one per line.

Sample Input

9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0

Sample Output

6
5

题解:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[100], v[100], n, len, cnt;
// 正在拼第stick根原始木棒(已经拼好了stick-1根)
// 第stick根木棒的当前长度为cab
// 拼接到第stick根木棒中的上一根小木棍为last
bool dfs(int stick, int cab, int last) {
	// 所有原始木棒已经全部拼好,搜索成功
	if (stick > cnt) return true;
	// 第stick根木棒已经拼好,去拼下一根
	if (cab == len) return dfs(stick + 1, 0, 1);
	int fail = 0; // 剪枝(2)
	// 剪枝(1):小木棍长度递减(从last开始枚举)
	for (int i = last; i <= n; i++)
		if (!v[i] && cab + a[i] <= len && fail != a[i]) {
			v[i] = 1;
			if (dfs(stick, cab + a[i], i + 1)) return true;
			fail = a[i];
			v[i] = 0; // 还原现场
			if (cab == 0 || cab + a[i] == len) return false; // 剪枝(3,4)
		}
	return false; // 所有分支均尝试过,搜索失败
}

int main() {
	while (cin >> n && n) {
		int sum = 0, val = 0, m = 0;
		for (int i = 1; i <= n; i++) {
			int x;
			scanf("%d", &x);
			if (x <= 50) {
				a[++m] = x;
				sum += a[m];
				val = max(val, a[m]);
			}
		}
		n = m;
		sort(a + 1, a + n + 1);
		reverse(a + 1, a + n + 1); 
		for (len = val; len <= sum; len++) {
			if (sum % len) continue;
			cnt = sum / len; // 原始木棒长度为len,共cnt根
			memset(v, 0, sizeof(v));
			if (dfs(1, 0, 1)) break;
		}
		cout << len << endl;
	}
}

猜你喜欢

转载自blog.csdn.net/qq_37867156/article/details/82628062