ZOJ 1914 Arctic Network

题目链接

Arctic Network

Time Limit: 2 Seconds Memory Limit: 65536 KB
The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel.

Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.
Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).

Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

Sample Input

1
2 4
0 100
0 300
0 600
150 750

Sample Output

212.13
213

题意:国防部想把北部前哨之间连接起来,在建立网络时,有两种技术:卫星频道和无线电收发器。卫星频道可以连接,不限制距离、;无线电限制距离,所有岗哨之间无线电型号相同,即最远通讯距离D相同。当然距离越远成本越高。找出可以连接所有岗哨,且花费最少的D;

分析:构建MST,距离最远的岗哨之间用卫星,距离近的用无线电

AC代码

#include <cmath>
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int N=1010;
struct node{
    int u,v,d;
}q[N*N];
int x[N],y[N],pre[N];
int S,P,cnt;
int distance(int i,int j){
    return (x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]);
}
void init(){
    for(int i=1;i<=P;i++){
        pre[i]=i;
    }
    cnt=0;
}
int Find(int x){
    if(x!=pre[x]) pre[x]=Find(pre[x]);
    return pre[x];
}
void join(int x,int y){
    int tx=Find(x);
    int ty=Find(y);
    if(tx!=ty){
        pre[ty]=tx;
    }
}
bool cmp(node a,node b){
    return a.d<b.d;
}
int Kru(){
    int cnt1=0,ans=0;
    sort(q,q+cnt,cmp);
    for(int i=0;i<cnt;i++){
        if(Find(q[i].u)!=Find(q[i].v)){
            join(q[i].u,q[i].v);
            cnt1++;
            if(cnt1==P-S){
                ans=q[i].d;
                break;
            }
        }
    }
    return ans;
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&S,&P);
        init();
        for(int i=1;i<=P;i++){
            scanf("%d%d",&x[i],&y[i]);
        }
        for(int i=1;i<=P;i++){
            for(int j=i+1;j<=P;j++){
                q[cnt].u=i;
                q[cnt].v=j;
                q[cnt++].d=distance(i,j);
            }
        }
        int ans=Kru();
        printf("%.2lf\n",sqrt((double)ans));
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/kun-/p/9716674.html