TOJ 2415 Arctic Network Prim 第K小边

2415: Arctic Network 

描述

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel. 
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts. 

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

输入

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).

输出

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

样例输入

1
2 4
0 100
0 300
0 600
150 750

样例输出

212.13

用prim板子求出最短生成树之后,修改一下ans,记录下最小生成树上的所有边,sort一下可得n-m+1条边。

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<string>
#include<algorithm>
#include<map>
#include<set>
#include<queue>
#include<vector>
using namespace std;
#define inf 0x3f3f3f3f
#define LL long long
int n,m;
double graph[501][501];
int vis[501];
double prim()
{
	memset(vis,0,sizeof vis);
	double ans[505*505],low[1005];
	int pos=0,ap=0;
	vis[0]=1;
	for(int i=0;i<n;i++)
	low[i]=graph[pos][i];
	for(int i=1;i<n;i++)
	{
		double min=inf;
		for(int j=0;j<n;j++)
		{
			if(!vis[j]&&min>low[j])
			{
				min=low[j];
				pos=j;
			}
		}
		vis[pos]=1;
		ans[ap++]=min;
		for(int k=1;k<=n;k++)
		{
			if(!vis[k]&&low[k]>graph[pos][k])
			low[k]=graph[pos][k];
		}
	}
	sort(ans,ans+ap);
	return ans[n-m-1];
}
int main()
{
	int i,j,t;
	double x[505],y[505];
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&m,&n);
		memset(graph,0,sizeof graph);
		for(i=0;i<n;i++)
		scanf("%lf%lf",&x[i],&y[i]);
		for(i=0;i<n;i++) 
		{
			for(j=i+1;j<n;j++) 
			graph[i][j]=graph[j][i]=sqrt((x[i]- x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i] - y[j]));
		}
		printf("%.2lf\n",prim());
	}	
}

猜你喜欢

转载自blog.csdn.net/thewise_lzy/article/details/81214761