【ZCMU3037】Block Towers(贪心)

题目链接

3037: Block Towers

Time Limit: 2 Sec  Memory Limit: 256 MB
Submit: 48  Solved: 20
[Submit][Status][Web Board]

Description

C. Block Towers

Students in a class are making towers of blocks. Each student makes a (non-zero) tower by stacking pieces lengthwise on top of each other. n of the students use pieces made of two blocks and m of the students use pieces made of three blocks.

The students don’t want to use too many blocks, but they also want to be unique, so no two students’ towers may contain the same number of blocks. Find the minimum height necessary for the tallest of the students' towers.

Input

 The first line of the input contains two space-separated integers n and m (0≤n,m≤1000000, n+m>0)− the number of students using two-block pieces and the number of students using three-block pieces, respectively.

Output

 Print a single integer, denoting the minimum possible height of the tallest tower.

Sample Input

1 3

Sample Output

9

HINT

 In the first case, the student using two-block pieces can make a tower of height 4, and the students using three-block pieces can make towers of height 3, 6, and 9 blocks. The tallest tower has a height of 9 blocks.

扫描二维码关注公众号,回复: 3359038 查看本文章

【题意】

有n个人用2层的砖块建塔,有m个人用3层的砖块建塔,每个人的塔的高度要求不同,求最少的砖块能构造的最高的塔的高度。

【解题思路】

被最高的塔的最小高度困扰了好久……

因为每个人建塔的高度要求不同,可以先考虑如果可以相同的话,可以建的最高的塔的最小高度肯定是max(2*n,3*m)。

比如n=4,m=3时n个人可建的塔为2 4 6 8  m个人可建的塔为3 6 9,但最小高度不是9,因为高度为6的塔重复了(事实上之后所有6的倍数的塔高都会重复,只需比较n和m的最小值是否大于6的倍数,如果大,肯定会存在重复),所以只需比较8和9的大小,因为8比9小,为了满足题意,就将8+2=10,最后再求个max(n,m)即可。

【代码】

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        n*=2;
        m*=3;
        int x=6;
        while(x<=min(n,m))
        {
            if(n<m)n+=2;
            else m+=3;
            x+=6;
        }
        printf("%d\n",max(n,m));
    }
    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/qq_39826163/article/details/82755949