2014ACM/ICPC亚洲区北京站-A Curious Matt

HDU - 5112

There is a curious man called Matt. 
One day, Matt's best friend Ted is wandering on the non-negative half of the number line. Matt finds it interesting to know the maximal speed Ted may reach. In order to do so, Matt takes records of Ted’s position. Now Matt has a great deal of records. Please help him to find out the maximal speed Ted may reach, assuming Ted moves with a constant speed between two consecutive records.

Input

The first line contains only one integer T, which indicates the number of test cases. 
For each test case, the first line contains an integer N (2 ≤ N ≤ 10000),indicating the number of records. 
Each of the following N lines contains two integers t i and x i (0 ≤ t i, x i ≤ 106), indicating the time when this record is taken and Ted’s corresponding position. Note that records may be unsorted by time. It’s guaranteed that all t i would be distinct.

Output

For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), and y is the maximal speed Ted may reach. The result should be rounded to two decimal places. 

Sample Input

2
3
2 2
1 1
3 4
3
0 3
1 5
2 0

Sample Output

Case #1: 2.00
Case #2: 5.00

Hint
In the first sample, Ted moves from 2 to 4 in 1 time unit. The speed 2/1 is maximal.
In the second sample, Ted moves from 5 to 0 in 1 time unit. The speed 5/1 is maximal.

结构体排序题。

#include<bits/stdc++.h>
using namespace std;
const int maxn=1e4+5;
int pos=0,n,t;
struct node
{
    int t;
    double x;
}p[maxn];

bool cmp(node a,node b)
{
    return a.t<b.t;
}
int main()
{
    scanf("%d",&t);
    for(int pos=1;pos<=t;pos++)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%d%lf",&p[i].t,&p[i].x);
        sort(p,p+n,cmp);
        double x1,v=(abs(p[1].x-p[0].x))/(p[1].t-p[0].t);
        for(int i=2;i<n;i++)
        {
            double x1=(abs(p[i].x-p[i-1].x))/(p[i].t-p[i-1].t);
            if(x1>v) v=x1;
        }
        printf("Case #%d: %.2f\n",pos,v);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_40829921/article/details/82813907