ACM/ICPC 2018亚洲区预选赛北京赛站网络赛 D【队列】

版权声明:但行好事,莫问前程。 https://blog.csdn.net/Li_Hongcheng/article/details/82824704

#1831 : 80 Days
时间限制:1000ms
单点时限:1000ms
内存限制:256MB
描述
80 Days is an interesting game based on Jules Verne’s science fiction “Around the World in Eighty Days”. In this game, you have to manage the limited money and time.

Now we simplified the game as below:

There are n cities on a circle around the world which are numbered from 1 to n by their order on the circle. When you reach the city i at the first time, you will get ai dollars (ai can even be negative), and if you want to go to the next city on the circle, you should pay bi dollars. At the beginning you have c dollars.

The goal of this game is to choose a city as start point, then go along the circle and visit all the city once, and finally return to the start point. During the trip, the money you have must be no less than zero.

Here comes a question: to complete the trip, which city will you choose to be the start city?

If there are multiple answers, please output the one with the smallest number.

输入
The first line of the input is an integer T (T ≤ 100), the number of test cases.

For each test case, the first line contains two integers n and c (1 ≤ n ≤ 106, 0 ≤ c ≤ 109). The second line contains n integers a1, …, an (-109 ≤ ai ≤ 109), and the third line contains n integers b1, …, bn (0 ≤ bi ≤ 109).

It’s guaranteed that the sum of n of all test cases is less than 106

输出
For each test case, output the start city you should choose.

提示
For test case 1, both city 2 and 3 could be chosen as start point, 2 has smaller number. But if you start at city 1, you can’t go anywhere.

For test case 2, start from which city seems doesn’t matter, you just don’t have enough money to complete a trip.

样例输入
2
3 0
3 4 5
5 4 3
3 100
-3 -4 -5
30 40 50
样例输出
2
-1

代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn=2e6+5;
long long a[maxn],b[maxn];

int main()
{
    int t;
    scanf("%d",&t);
    long long x;
    int n;
    while(t--)
    {
        queue<long long>q;
        scanf("%d%lld",&n,&x);
        for(int i=1; i<=n; i++)
        {
            scanf("%lld",&a[i]);
        }
        for(int i=1; i<=n; i++)
        {
            scanf("%lld",&b[i]);
        }
        for(int i=n+1;i<=n*2; i++)
        {
            a[i]=a[i-n];
            b[i]=b[i-n];
        }
        int flag=0;

        for(int i=1; i<=n*2; i++)
        {
            if(x+a[i]-b[i]>=0)
            {
                x+=a[i]-b[i];
                q.push(i);
                if(q.size()>=n)
                {
                    printf("%lld\n",q.front());
                    flag=1;
                    break;
                }
            }
            else
            {
                while(x+a[i]-b[i]<0&&q.size())
                {
                    x-=a[q.front()]-b[q.front()];
                    q.pop();
                }
                if(x+a[i]-b[i]>=0)
                {
                    x+=a[i]-b[i];
                    q.push(i);
                    if(q.size()>=n)
                    {
                        printf("%lld\n",q.front());
                        flag=1;
                        break;
                    }
                }
            }
        }
        if(flag==0)
        {
            printf("-1\n");
        }
    }
}

猜你喜欢

转载自blog.csdn.net/Li_Hongcheng/article/details/82824704