2014ACM/ICPC亚洲区北京站-H - Happy Matt Friends

HDU - 5119

Matt has N friends. They are playing a game together. 

Each of Matt’s friends has a magic number. In the game, Matt selects some (could be zero) of his friends. If the xor (exclusive-or) sum of the selected friends’magic numbers is no less than M , Matt wins. 

Matt wants to know the number of ways to win.

Input

The first line contains only one integer T , which indicates the number of test cases. 

For each test case, the first line contains two integers N, M (1 ≤ N ≤ 40, 0 ≤ M ≤ 10 6). 

In the second line, there are N integers ki (0 ≤ k i ≤ 10 6), indicating the i-th friend’s magic number.

Output

For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y indicates the number of ways where Matt can win.

Sample Input

2
3 2
1 2 3
3 3
1 2 3

Sample Output

Case #1: 4
Case #2: 2


        
  

Hint

In the first sample, Matt can win by selecting:
friend with number 1 and friend with number 2. The xor sum is 3.
friend with number 1 and friend with number 3. The xor sum is 2.
friend with number 2. The xor sum is 2.
friend with number 3. The xor sum is 3. Hence, the answer is 4.

滚动数组+dp

#include<bits/stdc++.h>
using namespace std;
const int maxn=(1<<21);
typedef long long ll;

int num[45];
ll dp[2][maxn];
 
int main()
{
    int T,m,n,i,j,cnt = 0;
    scanf("%d",&T);
    for(int cnt=1;cnt<=T;cnt++)
    {
        scanf("%d%d",&m,&n);
        for(i=1;i<=m;i++)
        {
            scanf("%d",&num[i]);
        }
        memset(dp,0,sizeof(dp));
        dp[0][0]=1;
        ll ans;
        for(i=1;i<=m;i++)
        {
            for(j=0;j<maxn;j++)
               dp[i%2][j] = dp[(i-1)%2][j]+dp[(i-1)%2][j^num[i]];
        }
        ans=0;
        for(j=n;j<maxn;j++)
        {
            ans+=dp[m%2][j];
        }
        printf("Case #%d: %lld\n",cnt,ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_40829921/article/details/82814096