Tomb Raider

Lara Croft, the fiercely independent daughter of a missing adventurer, must push herself beyond her limits when she discovers the island where her father disappeared. In this mysterious island, Lara finds a tomb with a very heavy door. To open the door, Lara must input the password at the stone keyboard on the door. But what is the password? After reading the research notes written in her father's notebook, Lara finds out that the key is on the statue beside the door.

The statue is wearing many arm rings on which some letters are carved. So there is a string on each ring. Because the letters are carved on a circle and the spaces between any adjacent letters are all equal, any letter can be the starting letter of the string. The longest common subsequence (let's call it "LCS") of the strings on all rings is the password. A subsequence is a sequence that can be derived from another sequence by deleting some or no elements without changing the order of the remaining elements.

For example, there are two strings on two arm rings: s1 = "abcdefg" and s2 = "zaxcdkgb". Then "acdg" is a LCS if you consider 'a' as the starting letter of s1, and consider 'z' or 'a' as the starting letter of s2. But if you consider 'd' as the starting letter of s1 and s2, you can get "dgac" as a LCS. If there are more than one LCS, the password is the one which is the smallest in lexicographical order.

Please find the password for Lara.

输入

There are no more than 10 test cases.

In each case:

The first line is an integer n, meaning there are n (0 < n ≤ 10) arm rings.

Then n lines follow. Each line is a string on an arm ring consisting of only lowercase letters. The length of the string is no more than 8.

输出

For each case, print the password. If there is no LCS, print 0 instead.

样例输入

2
abcdefg
zaxcdkgb
5
abcdef
kedajceu
adbac
abcdef
abcdafc
2
abc
def

样例输出

acdg
acd
0

题意大概就是有n个环,上面有字母,要你删除一些字母,使最后留下了的字母都一样,要让这个剩下的长度最长

思路:先找出最短的序列,这样最省时间;
然后用容斥定理,找出所有的子序列,最大O(2^8)
判断其他每个序列有没有这个子序列
判断的方法就是,先把每个序列变长一倍,然后开始找第一个符合的字符,再在接下来的原字符长度里找出符合的字符;
如果有一个不符合,那就不可以;
把所有符合的子序列放在一起,找出最长的那个子序列;
在把这个序列变成符合输出条件的,比如bcda,要输出abcd
可以变长一倍,然后找出原长度个序列,在sort一下就可以了

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include <iomanip>
#include<cmath>
#include<float.h> 
#include<string.h>
#include<algorithm>
#include<vector>
#include<queue>
#define sf scanf
#define pf printf
#define scf(x) scanf("%d",&x)
#define scff(x,y) scanf("%d%d",&x,&y)
#define scfff(x,y,z) scanf("%d%d%d",&x,&y,&z)
#define prf(x) printf("%d\n",x) 
#define mm(x,b) memset((x),(b),sizeof(x))
#define rep(i,a,n) for (int i=a;i<n;i++)
#define per(i,a,n) for (int i=a;i>=n;i--)
typedef long long ll;
const ll mod=1e9+7;
const double eps=1e-8;
const int inf=0x3f3f3f3f;
using namespace std;
const double pi=acos(-1.0);
const int N=1e5+10;
string a[10];
int len[10];
vector<string> qq;
string ans[10];
int main()
{
    int n;
    while(~scf(n))
    {
        qq.clear();
        rep(i,0,10)
        ans[i]="";//初始化
        int minn=11,pos;
        rep(i,0,n) 
        {
            cin>>a[i];                                          
            len[i]=a[i].length();   //记录每个的长度                       
            if(len[i]<minn)             //找出最短的序列 
            {                                           
                minn=len[i];                        
                pos=i;                                      
            }                                                   
            a[i]+=a[i];                         //长度翻倍 
        }                                               
        for(int i=1;i<(1<<minn);i++)                            
        {
            string v;
            for(int j=0;j<minn;j++)                 //找出子序列 
            {
                if((1<<j)&i)
                {
                    v+=a[pos][j];
                }
            }
            int temp=0;                             //标记能不能找到这个序列 
            for(int j=0;j<n;j++)                    // 循环n次 
            {
                int temp1=0;                        //标记这个序列能不能找到 
                if(j==pos) continue;                //如果就是最短那个 
                rep(k,0,len[j])                     //找一到n 
                {
                    int pos1=0;
                    if(a[j][k]==v[pos1])            //找符合后面的n个 
                    {
                        pos1++;
                        for(int l=1;l<len[j];l++)
                        {
                            if(a[j][k+l]==v[pos1])
                            {
                                pos1++;
                            }
                        }
                    }
                    if(pos1==v.length())                //如果这个符合了 
                    {
                        temp1=1;
                        break;
                    }
                }
                if(temp1==0)
                {
                    temp=1;
                    break;
                }
            }
            if(temp==0)                                                    //都能满足,放入vector
            {
                qq.push_back(v); 
            }
        }
        if(qq.empty())                                //如果没有,输出0
        {
            pf("0\n");
            continue;
        }
        int maxn=0;
        string t;
        rep(i,0,qq.size())                        //找出最长的
        {
            if(qq[i].size()>maxn)
            {
                maxn=qq[i].size();
                t=qq[i];
            }
        }
        t+=t;
        rep(i,0,maxn)
        {
            string aa;
            rep(j,0,maxn)
            {
                aa+=t[i+j];
            }
            ans[i]=aa;
        }
        sort(ans,ans+maxn);
        cout<<ans[0]<<endl;
    }
}

猜你喜欢

转载自www.cnblogs.com/wzl19981116/p/9690236.html
今日推荐