【hiho】2018ICPC北京赛区网络赛B Tomb Raider(暴力dfs)

题目链接

#1829 : Tomb Raider

时间限制:1000ms

单点时限:1000ms

内存限制:256MB

描述

Lara Croft, the fiercely independent daughter of a missing adventurer, must push herself beyond her limits when she discovers the island where her father disappeared. In this mysterious island, Lara finds a tomb with a very heavy door. To open the door, Lara must input the password at the stone keyboard on the door. But what is the password? After reading the research notes written in her father's notebook, Lara finds out that the key is on the statue beside the door.

The statue is wearing many arm rings on which some letters are carved. So there is a string on each ring. Because the letters are carved on a circle and the spaces between any adjacent letters are all equal, any letter can be the starting letter of the string. The longest common subsequence (let's call it "LCS") of the strings on all rings is the password. A subsequence is a sequence that can be derived from another sequence by deleting some or no elements without changing the order of the remaining elements.

For example, there are two strings on two arm rings: s1 = "abcdefg" and s2 = "zaxcdkgb". Then "acdg" is a LCS if you consider 'a' as the starting letter of s1, and consider 'z' or 'a' as the starting letter of s2. But if you consider 'd' as the starting letter of s1 and s2, you can get "dgac" as a LCS. If there are more than one LCS, the password is the one which is the smallest in lexicographical order.

Please find the password for Lara.

输入

There are no more than 10 test cases.

In each case:

The first line is an integer n, meaning there are n (0 < n ≤ 10) arm rings.

Then n lines follow. Each line is a string on an arm ring consisting of only lowercase letters. The length of the string is no more than 8.

输出

For each case, print the password. If there is no LCS, print 0 instead.

样例输入

2
abcdefg
zaxcdkgb
5
abcdef
kedajceu
adbac
abcdef
abcdafc
2
abc
def

样例输出

acdg
acd
0

【题意】

给n个字符串环,找这n个字符串环中的最长相同子串。

【解题思路】

用set存储每个字符串的所有子串,然后以第一个字符串为模板串,检查其他字符串中是否含有第一个字符串的子串,若含有并当前子串比之前找到的长或者和之前的一样长,但是比之前的小则更新答案。主要是dfs遍历字符串的所有子串的过程。

【代码】

#include<bits/stdc++.h>
using namespace std;
set<string> st[11];
string s,ans;
int len;
void dfs(int i,int cur)
{
    if(cur==len)
    {
        if(ans=="")return;
        st[i].insert(ans);
        int l=ans.size();
        for(int j=1;j<l;j++)
            st[i].insert(ans.substr(j,l-j)+ans.substr(0,j));
        return;
    }
    ans=ans+s[cur];
    //cout<<ans<<endl;
    dfs(i,cur+1);
    ans.erase(ans.end()-1);
    dfs(i,cur+1);
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=0;i<11;i++)st[i].clear();
        for(int i=0;i<n;i++)
        {
            cin>>s;
            len=s.size();
            ans="";
            dfs(i,0);
        }
        set<string>::iterator it;
        string a="0";
        for(it=st[0].begin();it!=st[0].end();it++)
        {
            int flag=0;
            for(int i=1;i<n;i++)
            {
                if(!st[i].count(*it))
                {
                    flag=1;
                    break;
                }
            }
            if(!flag)
            {
                if(a=="0" || ((*it).size()>a.size()))a=*it;
                else if((*it).size()==a.size() && (*it)<a)a=*it;
            }
        }
        cout<<a<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_39826163/article/details/82820711