1034:计算三角形面积

版权声明:请勿盗用 https://blog.csdn.net/ice___snow/article/details/82783617

时间限制: 1000 ms 内存限制: 65536 KB
提交数: 12700 通过数: 4006

【题目描述】

平面上有一个三角形,它的三个顶点坐标分别为(x1, y1), (x2, y2), (x3, y3),那么请问这个三角形的面积是多少,精确到小数点后两位。

【输入】

输入仅一行,包括6个单精度浮点数,分别对应x1, y1, x2, y2, x3, y3。

【输出】

输出也是一行,输出三角形的面积,精确到小数点后两位。

【输入样例】

0 0 4 0 0 3

【输出样例】

6.00

【来源】

No

【代码】

#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <iostream>
using namespace std;
int main()
{
    float x1,y1,x2,y2,x3,y3,t,s;
	cin>>x1>>y1>>x2>>y2>>x3>>y3;
	t=(x2-x1)*(y3-y1)-(x3-x1)*(y2-y1);
	s=abs(t)/2;
	printf("%.2f",s);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ice___snow/article/details/82783617