H - Can you answer these queries? HDU - 4027

H - Can you answer these queries?   HDU - 4027

A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help. 
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line. 

Notice that the square root operation should be rounded down to integer.

Input

The input contains several test cases, terminated by EOF. 
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000) 
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000) 
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive. 

Output

For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.

Sample Input

10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8

Sample Output

Case #1:
19
7
6

特别感谢100万遍,辛勤为女朋友debug的男朋友!!!!

//!!!!!特别注意此题输入输出问题,输入x可能大于y,输出格式要注意
//一个数绝对不可能被开方超过7次,如果这段区间和已经变成了r-l+1,就代表都是1,可以直接return
#include <bits/stdc++.h>
#define ll long long
using namespace std;
const int maxn=1e5+10;
ll sum[maxn*4];
int Q,x,y,n,m;

void build(int l,int r,int rt)
{
    if(l==r)
    {
        scanf("%lld",&sum[rt]);
        return;
    }
    int mid=(l+r)/2;
    build(l,mid,2*rt);
    build(mid+1,r,2*rt+1);
    sum[rt]=sum[rt*2]+sum[rt*2+1];
}

void update(int l,int r,int rt)
{
    if(x<=l&&y>=r&&sum[rt]==r-l+1) return;
    if(l==r)
    {
        sum[rt]=sqrt(sum[rt]);
        return;
    }
    int mid=(l+r)/2;
    if(x<=mid) update(l,mid,2*rt);
    if(y>mid)  update(mid+1,r,2*rt+1);
    sum[rt]=sum[rt*2]+sum[rt*2+1];
}

ll query(int l,int r,int rt)
{
    if(x<=l&&y>=r)
    {
        return sum[rt];
    }
    int mid=(l+r)/2;
    ll left=0,right=0;
    if(x<=mid) left+=query(l,mid,2*rt);
    if(y>mid)  right+=query(mid+1,r,2*rt+1);
    return left+right;
}

int main()
{
    int tot=1;
    while(scanf("%d",&n)!=EOF)
    {
        build(1,n,1);
        scanf("%d",&m);
        printf("Case #%d:\n",tot++);
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d%d",&Q,&x,&y);
            if(x>y) swap(x,y);
            if(Q==0)
            {
                update(1,n,1);
            }
            else
            {
                printf("%lld\n",query(1,n,1));
            }
        }
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41037114/article/details/81191957