find the longest of the shortest(最短路并记录路径)

hdu1595

Marica is very angry with Mirko because he found a new girlfriend and she seeks revenge.Since she doesn't live in the same city, she started preparing for the long journey.We know for every road how many minutes it takes to come from one city to another. 
Mirko overheard in the car that one of the roads is under repairs, and that it is blocked, but didn't konw exactly which road. It is possible to come from Marica's city to Mirko's no matter which road is closed. 
Marica will travel only by non-blocked roads, and she will travel by shortest route. Mirko wants to know how long will it take for her to get to his city in the worst case, so that he could make sure that his girlfriend is out of town for long enough.Write a program that helps Mirko in finding out what is the longest time in minutes it could take for Marica to come by shortest route by non-blocked roads to his city.

Input

Each case there are two numbers in the first row, N and M, separated by a single space, the number of towns,and the number of roads between the towns. 1 ≤ N ≤ 1000, 1 ≤ M ≤ N*(N-1)/2. The cities are markedwith numbers from 1 to N, Mirko is located in city 1, and Marica in city N. 
In the next M lines are three numbers A, B and V, separated by commas. 1 ≤ A,B ≤ N, 1 ≤ V ≤ 1000.Those numbers mean that there is a two-way road between cities A and B, and that it is crossable in V minutes.

Output

In the first line of the output file write the maximum time in minutes, it could take Marica to come to Mirko.

Sample Input

5 6
1 2 4
1 3 3
2 3 1
2 4 4
2 5 7
4 5 1

6 7
1 2 1
2 3 4
3 4 4
4 6 4
1 5 5
2 5 2
5 6 5

5 7
1 2 8
1 4 10
2 3 9
2 4 10
2 5 1
3 4 7
3 5 10

Sample Output

11
13
27

题意:m条路,去掉其中某一条路可分别得到一个最短路,求这些最短路中的最大值

//#include<bits/stdc++.h>
//#include <unordered_map>
//#include<unordered_set>
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<set>
#include<climits>
#include<queue>
#include<cmath>
#include<stack>
#include<map>
using namespace std;
#define ll long long
#define MT(a,b) memset(a,b,sizeof(a))
const int INF  =  0x3f3f3f3f;
const int ONF  = -0x3f3f3f3f;
const int mod  =  1e3;
const int maxn =  1e3+5;
const int N    =  1e9+5;
const double PI  =  3.141592653589;
const double E   =  2.718281828459;

int way[maxn][maxn];
int dis[maxn];
int vis[maxn];
int path[maxn];
int n, m;

int  Disj(int st ,int ed ,int flag)
{
    for(int i=0;i<n;i++) dis[i] = i==st?0:INF;
    MT(vis,0);
    for(int i=0;i<n;i++)
    {
        int k = 0, p = INF;
        for(int j=0;j<n;j++) if(!vis[j]&&dis[j]<p)  p = dis[k=j];
        vis [ k] = 1;
        for(int j=0;j<n;j++)
        {
            if(dis[j]>dis[k]+way[k][j])
            {
                dis[j] = dis[k]+way[k][j];
                if(flag) path[j] = k;
            }
        }
    }
    return dis[ed];
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=0;i<n;i++)for(int j=0;j<n;j++) way[i][j]=(i==j?0:INF);
        MT(path , 0); path[0] = -1;
        for(int i=0;i<m;i++)
        {
            int u, v, s;scanf("%d%d%d",&u,&v,&s);
            u--,v--; way[u][v] = way[v][u] = min(way[u][v],s);
        }
        Disj(0,n-1,1);
        int ans = 0, vul = INF, beh = n , k = n-1;
        while(path[k]!=-1)
        {
            way[beh][k] = way[k][beh] = vul;
            vul = way[k][path[k]]; beh = k;
            way[k][path[k]] = way[path[k]][k] = INF;
            ans = max(Disj(0,n-1,0),ans);
            k = path[k];
        }
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Mannix_Y/article/details/81485004