HDU-1595-find the longest of the shortest

find the longest of the shortest

Time Limit: 1000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4256    Accepted Submission(s): 1611

Problem Description

Marica is very angry with Mirko because he found a new girlfriend and she seeks revenge.Since she doesn't live in the same city, she started preparing for the long journey.We know for every road how many minutes it takes to come from one city to another.
Mirko overheard in the car that one of the roads is under repairs, and that it is blocked, but didn't konw exactly which road. It is possible to come from Marica's city to Mirko's no matter which road is closed.
Marica will travel only by non-blocked roads, and she will travel by shortest route. Mirko wants to know how long will it take for her to get to his city in the worst case, so that he could make sure that his girlfriend is out of town for long enough.Write a program that helps Mirko in finding out what is the longest time in minutes it could take for Marica to come by shortest route by non-blocked roads to his city.

Input

Each case there are two numbers in the first row, N and M, separated by a single space, the number of towns,and the number of roads between the towns. 1 ≤ N ≤ 1000, 1 ≤ M ≤ N*(N-1)/2. The cities are markedwith numbers from 1 to N, Mirko is located in city 1, and Marica in city N.
In the next M lines are three numbers A, B and V, separated by commas. 1 ≤ A,B ≤ N, 1 ≤ V ≤ 1000.Those numbers mean that there is a two-way road between cities A and B, and that it is crossable in V minutes.

output

In the first line of the output file write the maximum time in minutes, it could take Marica to come to Mirko.

Sample Input

5 6 1 2 4 1 3 3 2 3 1 2 4 4 2 5 7 4 5 1 6 7 1 2 1 2 3 4 3 4 4 4 6 4 1 5 5 2 5 2 5 6 5 5 7 1 2 8 1 4 10 2 3 9 2 4 10 2 5 1 3 4 7 3 5 10

Sample Output

11 13 27

Author

ailyanlu

Source

HDU 2007-Spring Programming Contest - Warm Up (1)

Recommen

题目大意:给出去n个城市的m条路线,现在有条路可能堵了,但是一定有能到达的路线,问去城市的最少时间是多少

思路:用dijkstra算法求出从第一个点到那座城市的距离,然后再枚举可能会堵的路,比较一下求出结果就可以了

代码:

#include<map>
#include<stack>
#include<cmath>
#include<queue>
#include<string>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
#define maxn 1100
#define inf 9999999
#define ll long long
int m,n,flag;
int e[maxn][maxn];
int dis[maxn];
int book[maxn];
int lujin[maxn];
void dijk(int a)
{
    int i,j,k,u,v,minn;
    for(i=1; i<=n; i++)
    {
        dis[i]=inf;
        book[i]=0;
    }
    dis[a]=0;
    for(i=1; i<=n; i++)
    {
        minn=inf;
        for(j=1; j<=n; j++)
        {
            if(book[j]==0&&dis[j]<minn)
            {
                u=j;
                minn=dis[j];
            }
        }
        book[u]=1;
        for(v=1; v<=n; v++)
        {
            if(dis[v]>dis[u]+e[u][v])
            {
                dis[v]=dis[u]+e[u][v];
                if(flag==0)
                {
                    lujin[v]=u;
                }
            }
        }
    }
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        int i,j,k,u,v,t1,t2,t3,minn;
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=n; j++)
            {
                if(i==j)
                    e[i][j]=0;
                else
                    e[i][j]=inf;
            }
        }
        for(i=1; i<=m; i++)
        {
            scanf("%d%d%d",&t1,&t2,&t3);
            if(e[t1][t2]>t3)
                e[t1][t2]=e[t2][t1]=t3;
        }
        flag=0;
        dijk(1);
        flag=1;
        int temp,maxx=dis[n];
        for(i=n; i>1; i=lujin[i])
        {
            temp=e[lujin[i]][i];
            e[lujin[i]][i]=inf;
            dijk(1);
            maxx=max(maxx,dis[n]);
            e[lujin[i]][i]=temp;
        }
        printf("%d\n",maxx);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lee371042/article/details/81080686