Halloween Costumes LightOJ - 1422 (区间dp)

LightOJ - 1422

Gappu has a very busy weekend ahead of him. Because, next weekend is Halloween, and he is planning to attend as many parties as he can. Since it's Halloween, these parties are all costume parties, Gappu always selects his costumes in such a way that it blends with his friends, that is, when he is attending the party, arranged by his comic-book-fan friends, he will go with the costume of Superman, but when the party is arranged contest-buddies, he would go with the costume of 'Chinese Postman'.

Since he is going to attend a number of parties on the Halloween night, and wear costumes accordingly, he will be changing his costumes a number of times. So, to make things a little easier, he may put on costumes one over another (that is he may wear the uniform for the postman, over the superman costume). Before each party he can take off some of the costumes, or wear a new one. That is, if he is wearing the Postman uniform over the Superman costume, and wants to go to a party in Superman costume, he can take off the Postman uniform, or he can wear a new Superman uniform. But, keep in mind that, Gappu doesn't like to wear dresses without cleaning them first, so, after taking off the Postman uniform, he cannot use that again in the Halloween night, if he needs the Postman costume again, he will have to use a new one. He can take off any number of costumes, and if he takes off k of the costumes, that will be the last k ones (e.g. if he wears costume A before costume B, to take off A, first he has to remove B).

Given the parties and the costumes, find the minimum number of costumes Gappu will need in the Halloween night.

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with a line containing an integer N (1 ≤ N ≤ 100) denoting the number of parties. Next line contains N integers, where the ith integer ci (1 ≤ ci ≤ 100) denotes the costume he will be wearing in party i. He will attend party 1 first, then party 2, and so on.

Output

For each case, print the case number and the minimum number of required costumes.

Sample Input

2

4

1 2 1 2

7

1 2 1 1 3 2 1

Sample Output

Case 1: 3

Case 2: 4

题意:有n天,每天穿特定的衣服,可以同时穿几件衣服,但是最外面的那件衣服必须是特定的那件,当脱掉一件衣服后,该衣服就视为不干净,不能再穿,问经过这n天,至少需要多少件衣服。

题解:区间dp,dp [i] [j] 表示区间 i ~ j 最少需要的衣服,初始化,dp [i] [j] = dp [i] [j-1] + 1, 初始化理解很简单。然后,再在区间   [ i,j-1 )  中找是否有某一天 ( k ) 衣服和第 j 天的衣服一样,若一样 dp [i] [j] = min( dp [i] [j] , dp [i] [k] + dp [k+1] [j-1] ),该dp方程的意思是,第k天穿上该衣服后,后来几天都不脱第k天的那件衣服,直到第j天,脱掉其他的衣服露出第k天的那件衣服,从而满足第j天特定衣服的条件,最终便容易得到该dp方程。

ac代码:

//#include<bits/stdc++.h>
//#include <unordered_map>
//#include<unordered_set>
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<set>
#include<climits>
#include<queue>
#include<cmath>
#include<stack>
#include<map>
using namespace std;
#define LL long long
#define ULL unsigned long long
#define MT(a,b) memset(a,b,sizeof(a))
const int INF  =  0x3f3f3f3f;
const int ONF  = -0x3f3f3f3f;
const int O    =  1e5;
const int MOD  =  1e4+7;
const int maxn =  1e2+5;
const int N    =  1e9+5;
const double PI  =  3.141592653589;
const double E   =  2.718281828459;

int dp[maxn][maxn];

int main()
{
    int T;scanf("%d",&T);
    int l =0;
    while(T--)
    {
        int n;scanf("%d",&n);
        int a[maxn]; MT(a,0);
        for(int i=0;i<n;i++) scanf("%d",&a[i]);
        for(int i=0;i<n;i++) dp[i][i]= 1;
        for(int len = 2;len<=n; len++) for(int i=0;i<n;i++)
        {
            int j = len + i -1;
            if(j>=n) break;
            dp[i][j] = dp[i][j-1] + 1;
            for(int k=i;k<=j-1;k++) if(a[k]==a[j])
                dp[i][j] = min(dp[i][j], dp[i][k] + dp[k+1][j-1]);
        }
        printf("Case %d: %d\n",++l,dp[0][n-1]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Mannix_Y/article/details/82258506