Halloween Costumes LightOJ - 1422

Halloween Costumes LightOJ - 1422
Gappu has a very busy weekend ahead of him. Because, next weekend is Halloween, and he is planning to attend as many parties as he can. Since it’s Halloween, these parties are all costume parties, Gappu always selects his costumes in such a way that it blends with his friends, that is, when he is attending the party, arranged by his comic-book-fan friends, he will go with the costume of Superman, but when the party is arranged contest-buddies, he would go with the costume of ‘Chinese Postman’.

Since he is going to attend a number of parties on the Halloween night, and wear costumes accordingly, he will be changing his costumes a number of times. So, to make things a little easier, he may put on costumes one over another (that is he may wear the uniform for the postman, over the superman costume). Before each party he can take off some of the costumes, or wear a new one. That is, if he is wearing the Postman uniform over the Superman costume, and wants to go to a party in Superman costume, he can take off the Postman uniform, or he can wear a new Superman uniform. But, keep in mind that, Gappu doesn’t like to wear dresses without cleaning them first, so, after taking off the Postman uniform, he cannot use that again in the Halloween night, if he needs the Postman costume again, he will have to use a new one. He can take off any number of costumes, and if he takes off k of the costumes, that will be the last k ones (e.g. if he wears costume A before costume B, to take off A, first he has to remove B).

Given the parties and the costumes, find the minimum number of costumes Gappu will need in the Halloween night.

Input
Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with a line containing an integer N (1 ≤ N ≤ 100) denoting the number of parties. Next line contains N integers, where the ith integer ci (1 ≤ ci ≤ 100) denotes the costume he will be wearing in party i. He will attend party 1 first, then party 2, and so on.

Output
For each case, print the case number and the minimum number of required costumes.

Sample Input
2
4
1 2 1 2
7
1 2 1 1 3 2 1
Sample Output
Case 1: 3
Case 2: 4

分析:
题目的意思就是Gappu要去参加party,然后需要穿相应的衣服,衣服用数字表示,给你第i场party需要穿的衣服,求需要的最少衣服,注意脱下来后不能再穿回去。
定义状态dp[i][j]:从第i场party到第j场party需要穿的最少的衣服。
还是把区间分割:
dp[i][j]=dp[i][k]+dp[k+1][j],其中需要costume[j]==costume[k]
初始化:
dp[i][i]=1;

Accepted code:

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;
const int maxn=105;
int costume[maxn];
int dp[maxn][maxn];

int main()
{
    int t;
    cin>>t;
    int kase=1;
    while(t--)
    {

        int n;
        cin>>n;
        for(int i=0;i<n;i++)
            cin>>costume[i];

        memset(dp,0,sizeof(dp));

        for(int i=0;i<n;i++)
            for(int j=i;j<n;j++)
                dp[i][j]=j-i+1;

        for(int i=n-1;i>=0;i--)
        {
            for(int j=i+1;j<n;j++)
            {
                //turn off costume
                int temp=0x3f3f3f3f;
                for(int k=i;k<j;k++)
                    if(costume[k]==costume[j])
                        temp=min(temp,dp[i][k]+dp[k+1][j-1]);
                //dress up
                dp[i][j]=min(temp,dp[i][j-1]+1);
            }
        }

        cout<<"Case "<<kase++<<": "<<dp[0][n-1]<<endl;
    }
}

猜你喜欢

转载自blog.csdn.net/QingyingLiu/article/details/80687205