ACM-ICPC 2018 徐州赛区网络预赛-J:Maze Designer(最大生成树+LCA)

版权声明:http://blog.csdn.net/Mitsuha_。 https://blog.csdn.net/Mitsuha_/article/details/82588660

After the long vacation, the maze designer master has to do his job. A tour company gives him a map which is a rectangle. The map consists of N × M little squares. That is to say, the height of the rectangle is N and the width of the rectangle is M . The master knows exactly how the maze is going to use. The tour company will put a couple in two different squares in the maze and make them seek each other. Of course,the master will not make them find each other easily. The only thing the master does is building some wall between some little squares. He knows in that way, wherever the couple is put, there is only one path between them. It is not a difficult thing for him, but he is a considerate man. He also knows that the cost of building every wall between two adjacent squares is different(Nobody knows the reason). As a result, he designs the maze to make the tour company spend the least money to build it.

Now, here’s your part. The tour company knows you’re the apprentice of the master, so they give you a task. you’re given Q qustions which contain the information of where the couple will be put. You need to figure out the length of the shortest path between them.

However,the master doesn’t tell you how he designs the maze, but he believes that you, the best student of himself, know the way. So he goes on vacation again.

Input
The first line of the input contains two integers N and M ( 1 N , M 500 ) , giving the number of rows and columns of the maze.

The next N × M lines of the input give the information of every little square in the maze, and their coordinates are in order of ( 1 , 1 ) , ( 1 , 2 ) ( 1 , M ) , ( 2 , 1 ) , ( 2 , 2 ) , , ( 2 , M ) , , ( N , M ) .

Each line contains two characters D and R and two integers a , b ( 0 a , b 2000000000 ) , a is the cost of building the wall between it and its lower adjacent square, and b is the cost of building the wall between it and its right adjacent square. If the side is boundary, the lacking path will be replaced with X 0 .

The next line contains an integer Q ( 1 Q 100000 ) , which represents the number of questions.

The next Q lines gives four integers, x 1 , y 1 , x 2 , y 2 ( 1 x 1 , x 2 N , 1 y 1 , y 2 M ) , which represent two squares and their coordinate are ( x 1 , y 1 ) and ( x 2 , y 2 ) .

( x , y ) means row x and column y .

It is guaranteed that there is only one kind of maze.

Output
For each question, output one line with one integer which represents the length of the shortest path between two given squares.

样例输入
3 3
D 1 R 9
D 7 R 8
D 4 X 0
D 2 R 6
D 12 R 5
D 3 X 0
X 0 R 10
X 0 R 11
X 0 X 0
3
1 1 3 3
1 2 3 2
2 2 3 1
样例输出
4
2
2

思路:因为要求所有格点连通且任意2点之间只有一条路径,那么这些点应该构成一棵树,把围墙花费当成边权,然后求出最大生成树。

求出树的结构后,询问就是求树上任意2点间的最短路径了,用LCA即可。

#include<bits/stdc++.h>
using namespace std;
const int MAX=5e5+10;
const int MOD=1e9+7;
const double PI=acos(-1.0);
typedef long long ll;
struct lenka{int x,y,z;}ed[MAX];
int cmp(const lenka& A,const lenka& B){return A.z>B.z;}
int p[MAX];
int f(int x){return p[x]==x?x:p[x]=f(p[x]);}
vector<int>e[MAX];
int nex[MAX][21],d[MAX];
void dfs(int k,int fa,int dep)
{
    d[k]=dep;
    nex[k][0]=fa;
    for(int i=1;i<=20;i++)nex[k][i]=nex[nex[k][i-1]][i-1];
    for(int i=0;i<e[k].size();i++)
    {
        int nex=e[k][i];
        if(nex==fa)continue;
        dfs(nex,k,dep+1);
    }
}
int LCA(int x,int y)
{
    if(x==y)return x;
    if(d[x]>d[y])swap(x,y);
    for(int i=20;i>=0;i--)
    {
        if(d[x]<d[y]&&d[nex[y][i]]>=d[x])y=nex[y][i];
    }
    for(int i=20;i>=0;i--)
    {
        if(nex[x][i]!=nex[y][i])
        {
            x=nex[x][i];
            y=nex[y][i];
        }
    }
    if(x!=y)return nex[x][0];
    return x;
}
int main()
{
    int n,m,tot=0;
    cin>>n>>m;
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=m;j++)
        {
            char op[3];
            int x;
            scanf("%s%d",op,&x);
            if(op[0]=='D')
            {
                ed[++tot].x=(i-1)*m+j;
                ed[tot].y=i*m+j;
                ed[tot].z=x;
            }
            scanf("%s%d",op,&x);
            if(op[0]=='R')
            {
                ed[++tot].x=(i-1)*m+j;
                ed[tot].y=(i-1)*m+j+1;
                ed[tot].z=x;
            }
        }
    }
    sort(ed+1,ed+tot+1,cmp);
    for(int i=1;i<=n*m;i++)p[i]=i;
    for(int i=1;i<=tot;i++)
    {
        int fx=f(ed[i].x);
        int fy=f(ed[i].y);
        if(fx==fy)continue;
        p[fx]=fy;
        e[ed[i].x].push_back(ed[i].y);
        e[ed[i].y].push_back(ed[i].x);
    }
    dfs(1,0,1);
    int QWQ;
    cin>>QWQ;
    while(QWQ--)
    {
        int x1,y1,x2,y2;
        scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
        x1=(x1-1)*m+y1;
        x2=(x2-1)*m+y2;
        int lca=LCA(x1,x2);
        printf("%d\n",d[x1]+d[x2]-2*d[lca]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Mitsuha_/article/details/82588660