2018ICPC南京站网络赛 AC Challenge(状压dp)

Dlsj is competing in a contest with n (0 < n \le 20)n(0<n≤20) problems. And he knows the answer of all of these problems.

However, he can submit ii-th problem if and only if he has submitted (and passed, of course) s_isi​ problems, the p_{i, 1}pi,1​-th, p_{i, 2}pi,2​-th, ......, p_{i, s_i}pi,si​​-th problem before.(0 < p_{i, j} \le n,0 < j \le s_i,0 < i \le n)(0<pi,j​≤n,0<j≤si​,0<i≤n) After the submit of a problem, he has to wait for one minute, or cooling down time to submit another problem. As soon as the cooling down phase ended, he will submit his solution (and get "Accepted" of course) for the next problem he selected to solve or he will say that the contest is too easy and leave the arena.

"I wonder if I can leave the contest arena when the problems are too easy for me."
"No problem."
—— CCF NOI Problem set

If he submits and passes the ii-th problem on tt-th minute(or the tt-th problem he solve is problem ii), he can get t \times a_i + b_it×ai​+bi​ points. (|a_i|, |b_i| \le 10^9)(∣ai​∣,∣bi​∣≤109).

Your task is to calculate the maximum number of points he can get in the contest.

Input

The first line of input contains an integer, nn, which is the number of problems.

Then follows nn lines, the ii-th line contains s_i + 3si​+3 integers, a_i,b_i,s_i,p_1,p_2,...,p_{s_i}ai​,bi​,si​,p1​,p2​,...,psi​​as described in the description above.

Output

Output one line with one integer, the maximum number of points he can get in the contest.

Hint

In the first sample.

On the first minute, Dlsj submitted the first problem, and get 1 \times 5 + 6 = 111×5+6=11 points.

On the second minute, Dlsj submitted the second problem, and get 2 \times 4 + 5 = 132×4+5=13 points.

On the third minute, Dlsj submitted the third problem, and get 3 \times 3 + 4 = 133×3+4=13 points.

On the forth minute, Dlsj submitted the forth problem, and get 4 \times 2 + 3 = 114×2+3=11 points.

On the fifth minute, Dlsj submitted the fifth problem, and get 5 \times 1 + 2 = 75×1+2=7 points.

So he can get 11+13+13+11+7=5511+13+13+11+7=55 points in total.

In the second sample, you should note that he doesn't have to solve all the problems.

样例输入1复制

5
5 6 0
4 5 1 1
3 4 1 2
2 3 1 3
1 2 1 4

样例输出1复制

55

样例输入2复制

1
-100 0 0

样例输出2复制

0

思路:因为获得最大值和选取的顺序有关,所以状压可以做到,dp[i][sta]表示最后一个是i,且已选状态为sta时的最大值,i可以直接滚动掉,状压的时候要注意,只有当限制条件都在sta里的时候才能转移,所以用vector来存限制的条件(因为这个wa了8发)

代码:

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn=1e5+9;
const int mod=1e9+7;
#define inf 0x3f3f3f3f
int n;
vector<int> mp[30];
ll dp[1<<20];
struct Point
{
    ll a,b;
}p[23];
int getnum(int s)
{
    int ans=0;
    while(s)
    {
        if(s&1) ans++;
        s>>=1;
    }
    return ans;
}
bool judge(int sta,int i)
{
    if((sta&(1<<i))==0) return false;
    if(dp[sta^(1<<i)]==-1) return false;
    for (auto &t: mp[i])
    {
        if((sta&(1<<t))==0)
        {
            return false;
        }
    }
    return true;
}
int main()
{
    #ifndef ONLINE_JUDGE
        freopen("in.txt","r",stdin);
        freopen("out.txt","w",stdout);
    #endif
    while(scanf("%d",&n)!=EOF)
    {
    int sii=0;
    for(int i=0;i<n;i++) mp[i].clear();
    for(int i=0;i<n;i++)
    {
        int si;
        scanf("%lld%lld%d",&p[i].a,&p[i].b,&si);
        for(int j=0;j<si;j++)
        {
            int x;
            scanf("%d",&x);
            mp[i].push_back(x-1);
        }
    }
    ll ans=0;
    int sta=(1<<n)-1;
    memset(dp,-1,sizeof(dp));
    dp[0]=0;
    for(int s=0;s<=sta;s++)
    {
        for(int i=0;i<n;i++)
        {
            if(judge(s,i))
            {
                dp[s]=max(dp[s],dp[s^(1<<i)]+p[i].a*getnum(s)+p[i].b);
                ans=max(ans,dp[s]);
            }
        }
    }
    printf("%lld\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40774175/article/details/82291366