poj 1041 John's trip 欧拉回路 输出路径 模板

版权声明:本博客内容基本为原创,如有问题欢迎联系,转载请注明出处 https://blog.csdn.net/qq_41955236/article/details/82219965

John's trip

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10112   Accepted: 3424   Special Judge

Description

Little Johnny has got a new car. He decided to drive around the town to visit his friends. Johnny wanted to visit all his friends, but there was many of them. In each street he had one friend. He started thinking how to make his trip as short as possible. Very soon he realized that the best way to do it was to travel through each street of town only once. Naturally, he wanted to finish his trip at the same place he started, at his parents' house. 

The streets in Johnny's town were named by integer numbers from 1 to n, n < 1995. The junctions were independently named by integer numbers from 1 to m, m <= 44. No junction connects more than 44 streets. All junctions in the town had different numbers. Each street was connecting exactly two junctions. No two streets in the town had the same number. He immediately started to plan his round trip. If there was more than one such round trip, he would have chosen the one which, when written down as a sequence of street numbers is lexicographically the smallest. But Johnny was not able to find even one such round trip. 

Help Johnny and write a program which finds the desired shortest round trip. If the round trip does not exist the program should write a message. Assume that Johnny lives at the junction ending the street appears first in the input with smaller number. All streets in the town are two way. There exists a way from each street to another street in the town. The streets in the town are very narrow and there is no possibility to turn back the car once he is in the street 

Input

Input file consists of several blocks. Each block describes one town. Each line in the block contains three integers x; y; z, where x > 0 and y > 0 are the numbers of junctions which are connected by the street number z. The end of the block is marked by the line containing x = y = 0. At the end of the input file there is an empty block, x = y = 0.

Output

Output one line of each block contains the sequence of street numbers (single members of the sequence are separated by space) describing Johnny's round trip. If the round trip cannot be found the corresponding output block contains the message "Round trip does not exist."

Sample Input

1 2 1
2 3 2
3 1 6
1 2 5
2 3 3
3 1 4
0 0
1 2 1
2 3 2
1 3 3
2 4 4
0 0
0 0

Sample Output

1 2 3 5 4 6 
Round trip does not exist.

题意: 

       给你每两个房屋由哪条路连接,如果存在欧拉回路就输出最小字典序的路径,如果不存在则输出“Round trip does not exist.”。

 做法:

      初学欧拉回路,通过网上代码学到了欧拉回路这种新的表达方法,就是这题做的过程有点繁琐,有点心塞。


代码如下:

     

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
typedef long long ll;
int mp[50][2000],vis[2000],ans[2005],now=0;
int in[55],nroads,nhouse;
void add(int x,int y,int z){
    mp[x][z]=y,mp[y][z]=x;
    in[x]^=1;in[y]^=1;
}
void dfs(int x,int n){
    for(int i=1;i<=n;i++){
        if(mp[x][i]&&!vis[i]){
            vis[i]=1;
            dfs(mp[x][i],n);
            ans[++now]=i;
        }
    }
}
void init(){
    mem(mp,0); mem(vis,0); mem(ans,0);
    nroads=nhouse=0; now=0; mem(in,0);
}
int main(){
    int x,y,z,st;
    while(~scanf("%d%d",&x,&y)){
        init();
        if(x==0&&y==0) break;
        scanf("%d",&z);
        nhouse=max(x,y);
        nroads=z;
        st=min(x,y);
        add(x,y,z);
        while(~scanf("%d%d",&x,&y)){
            if(x==0&&y==0) break;
            scanf("%d",&z);
            add(x,y,z);
            nroads=max(nroads,z);
            nhouse=max(nhouse,max(x,y));
        }
        int flag=0;
        for(int i=1;i<=nhouse;i++){
            if(in[i]) {
                flag=1;
                break;
            }
        }
        if(flag){
            printf("Round trip does not exist.\n");
            continue;
        }
        dfs(st,nroads);
        for(int i=now;i>=1;i--){
            printf("%d%c",ans[i],i==1?'\n':' ');
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41955236/article/details/82219965