John's trip POJ - 1041

一、内容

Little Johnny has got a new car. He decided to drive around the town to visit his friends. Johnny wanted to visit all his friends, but there was many of them. In each street he had one friend. He started thinking how to make his trip as short as possible. Very soon he realized that the best way to do it was to travel through each street of town only once. Naturally, he wanted to finish his trip at the same place he started, at his parents' house.

The streets in Johnny's town were named by integer numbers from 1 to n, n < 1995. The junctions were independently named by integer numbers from 1 to m, m <= 44. No junction connects more than 44 streets. All junctions in the town had different numbers. Each street was connecting exactly two junctions. No two streets in the town had the same number. He immediately started to plan his round trip. If there was more than one such round trip, he would have chosen the one which, when written down as a sequence of street numbers is lexicographically the smallest. But Johnny was not able to find even one such round trip.

Help Johnny and write a program which finds the desired shortest round trip. If the round trip does not exist the program should write a message. Assume that Johnny lives at the junction ending the street appears first in the input with smaller number. All streets in the town are two way. There exists a way from each street to another street in the town. The streets in the town are very narrow and there is no possibility to turn back the car once he is in the street

Input

Input file consists of several blocks. Each block describes one town. Each line in the block contains three integers x; y; z, where x > 0 and y > 0 are the numbers of junctions which are connected by the street number z. The end of the block is marked by the line containing x = y = 0. At the end of the input file there is an empty block, x = y = 0. 

Output

Output one line of each block contains the sequence of street numbers (single members of the sequence are separated by space) describing Johnny's round trip. If the round trip cannot be found the corresponding output block contains the message "Round trip does not exist." 

Sample Input

1 2 1
2 3 2
3 1 6
1 2 5
2 3 3
3 1 4
0 0
1 2 1
2 3 2
1 3 3
2 4 4
0 0
0 0

Sample Output

1 2 3 5 4 6 
Round trip does not exist.

二、思路

  • x,y是2个路口,他们通过一条边z相连。询问是否存在一条路径使所有的边只经过一次。
  • 首先判断一下是否有欧拉路径,判断是否每个点的度数是偶数,若是则存在。
  • 若存在欧拉路径,那么就dfs进行搜索一下,由于我们必须按照字典序小的答案进行输出。所以我们用mp[i][j] 代表第i个点同过j街道 连接的点是mp[i][j] 。 然后dfs的时候从1-m开时循环每一条边。

三、代码

#include <cstdio>
#include <algorithm> 
#include <iostream>
#include <cstring>
using namespace std;
const int N = 50, M = 2005;
int x, y, z, n, mp[N][M], s, m, cnt, de[N], rec[M]; //mp[i][j] 代表第i个点同过j街道 连接的点是mp[i][j] 
bool vis[M];
void dfs(int u) {
	for (int i = 1; i <= m; i++) {
		//找到u连接的一条边
		if (!vis[i] && mp[u][i]) {
			vis[i] = true;
			dfs(mp[u][i]);
			//记录路径
			rec[++cnt] = i; 
		} 
	}
}
int main() {
	while (scanf("%d%d", &x, &y), x) {
		m = 0;
		memset(mp, 0, sizeof(mp));
		memset(de, 0, sizeof(de));
		s = min(x, y); //记录起点
		scanf("%d", &z);
		mp[x][z] = y;
		mp[y][z] = x;
		de[x]++; //记录度数 
		de[y]++; 
		n = max(x, y); //记录最大的点数 
		m++; //记录边的数量
		while (scanf("%d%d", &x, &y), x) {
			scanf("%d", &z);
			mp[x][z] = y;
			mp[y][z] = x;
			m++; //记录边的数量
			de[x]++; //记录度数 
			de[y]++; 
			n = max(x, y);
		} 
		bool ok = true;
		for (int i = 1; i <= n; i++) {
			if (de[i] % 2 == 1) {
				//欧拉图的判定 当且仅当无向图连通,每个点的度数都为偶数 
				ok = false;
				break;
			}
		}
		if (ok) {
			cnt = 0;
			memset(vis, false, sizeof(vis));
			dfs(s);
			for (int i = cnt; i >= 1; i--) printf("%d ", rec[i]);
			printf("\n"); 
		} else {
			printf("Round trip does not exist.\n");
		}
  	}
	return 0;
}
发布了343 篇原创文章 · 获赞 244 · 访问量 4万+

猜你喜欢

转载自blog.csdn.net/qq_41280600/article/details/103928931