HDU 6208【假AC自动机+string方法】

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_37867156/article/details/81543747

题目链接:http://acm.hdu.edu.cn/listproblem.php?vol=1

The Dominator of Strings

Time Limit: 3000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 4746    Accepted Submission(s): 1619

Problem Description

Here you have a set of strings. A dominator is a string of the set dominating all strings else. The string S is dominated by T if S is a substring of T.

Input

The input contains several test cases and the first line provides the total number of cases.
For each test case, the first line contains an integer N indicating the size of the set.
Each of the following N lines describes a string of the set in lowercase.
The total length of strings in each case has the limit of 100000.
The limit is 30MB for the input file.

Output

For each test case, output a dominator if exist, or No if not.

Sample Input

3

10

you

better

worse

richer

poorer

sickness

health

death

faithfulness

youbemyweddedwifebetterworsericherpoorersicknesshealthtilldeathdouspartandpledgeyoumyfaithfulness

5

abc

cde

abcde

abcde

bcde

3

aaaaa

aaaab

aaaac

Sample Output

youbemyweddedwifebetterworsericherpoorersicknesshealthtilldeathdouspartandpledgeyoumyfaithfulness

abcde

No

题解:网上好多巨佬用AC自动机、奈何水平有限,AC自动机不会啊,只好用string的方法了。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <queue>
#include <stack>
#include <string>
#include <set>
#include <map>
#define INF 0x3f3f3f3f
#define LL long long
using namespace std;
const int maxn=500005;
string s[maxn];
int main(){
	int t,n;
	cin.sync_with_stdio(false);//这里不加会超时
	cin>>t;
	while(t--){
		cin>>n;
		int maxx=-1,id;
		for(int i=0;i<n;i++){
			cin >> s[i];
			int len=s[i].length();
			if(len>maxx){
				maxx=len;
				id=i;
			}
		}
		int flag=0;
		for(int i=0;i<n;i++){
			if(s[id].find(s[i])!=-1){
				flag=1;
			}else{
				flag=0;
				break;
			}
		}
		if(!flag) cout<<"No\n";
		else cout<<s[id]<<endl;
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37867156/article/details/81543747
今日推荐