3-7 类的友元函数的应用

版权声明:本文为博主原创文章,转载时注明出处,附加链接即可。 https://blog.csdn.net/cswhit/article/details/53364905

3-7 类的友元函数的应用

Time Limit: 1000MS  Memory Limit: 65536KB

Problem Description

通过本题目的练习可以掌握类的友元函数的定义和用法
要求设计一个点类Point,它具有两个double型的数据成员x,y。为该类设计构造函数。并为其添加一个友元函数用于计算并输出两点间的距离;再添加一个输出成员函数用于输出点的信息。
 
 
并编写主函数,实现以下的输入输出内容。

Input

4double型的数,中间用一个空格间隔。

Output

输出数据共3行,前两行用于显示要求距离的两个点的信息,第三行显示两点的距离。

Example Input

5 6 2 3

Example Output

The first point is the coordinate:X=5,Y=6
The second point is the coordinate:X=2,Y=3
The distance between the two points is:4.24264

#include <iostream>
#include <math.h>
using namespace std;
int k=0;
class Point
{
private:
    double x,y;
    friend void print(Point& t1,Point& t2);//据说,友元函数一般放在私有里
public:
    Point(double a,double b)
    {
        x=a;
        y=b;
    }
    void show()
    {
        if(k==0)
        {
            cout<<"The first point is the coordinate:X="<<x<<",Y="<<y<<endl;
            k=1;
        }
        else
        {
            cout<<"The second point is the coordinate:X="<<x<<",Y="<<y<<endl;
        }
    }

};
void print(Point& t1,Point& t2)
{
    cout<<"The distance between the two points is:"<<sqrt((t1.x-t2.x)*(t1.x-t2.x)+(t1.y-t2.y)*(t1.y-t2.y))<<endl;
}
int main()
{
    double a,b,c,d;
    cin>>a>>b>>c>>d;
    Point t1(a,b),t2(c,d);
    k=0;
    t1.show();
    t2.show();
    print(t1,t2);
    return 0;
}


猜你喜欢

转载自blog.csdn.net/cswhit/article/details/53364905