POJ2492(并查集)

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output
The output for every scenario is a line containing “Scenario #i:”, where i is the number of the scenario starting at 1, followed by one line saying either “No suspicious bugs found!” if the experiment is consistent with his assumption about the bugs’ sexual behavior, or “Suspicious bugs found!” if Professor Hopper’s assumption is definitely wrong.
Sample Input
2
3 3
1 2
2 3
1 3
4 2
1 2
3 4
Sample Output
Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!
Hint
Huge input,scanf is recommended.
敌人的敌人就是我的敌人,如果不符合这个条件就算是不正常。

#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define MAXN 2005
using namespace std;

int bin[MAXN];
int diff[MAXN];

int findx(int x)
{
    int r = x;
    while(r!=bin[r])
    {
        r = bin[r];
    }
    int k = x,j;
    while(k!=r)
    {
        j = bin[k];
        bin[k] = r;
        k = j;
    }
    return r;
}

void merrg(int x,int y)
{
    int fx = findx(x);
    int fy = findx(y);
    if(fx!=fy)
    {
        bin[fx] = fy;
    }
}

int main()
{
    int t;
    int pp=1;
    scanf("%d",&t);
    int nn = t;
    while(t--){
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++){
            bin[i] = i;
        }
        memset(diff,0,sizeof(diff));
        int m;
        scanf("%d",&m);
        int result = true;
        for(int i=0;i<m;i++){
            int a,b;
            scanf("%d%d",&a,&b);
            if(!result)
                continue;
            if(findx(a)==findx(b)){
                result = false;
                continue;
            }
            if(diff[a]){
                merrg(diff[a],b);
            }
            else{
                diff[a] = b;
            }
            if(diff[b]){
                merrg(diff[b],a);
            }
            else{
                diff[b] = a;
            }
        }
        if(result)
            printf("Scenario #%d:\nNo suspicious bugs found!\n",pp++);
        else{
            printf("Scenario #%d:\nSuspicious bugs found!\n",pp++);
        }
        if(pp!=nn+2){
            printf("\n");
        }

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_40488730/article/details/81586804