uva 11111 Generalized Matrioshkas

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/tengfei461807914/article/details/81867495

原题:
Vladimir worked for years making matrioshkas, those nesting dolls that certainly represent truly Russian
craft. A matrioshka is a doll that may be opened in two halves, so that one finds another doll inside.
Then this doll may be opened to find another one inside it. This can be repeated several times, till a final doll -that cannot be opened- is reached.
Recently, Vladimir realized that the idea of nesting dolls might be generalized to nesting toys.
Indeed, he has designed toys that contain toys but in a more general sense. One of these toys may be opened in two halves and it may have more than one toy inside it. That is the new feature that Vladimir wants to introduce in his new line of toys.
Vladimir has developed a notation to describe how nesting toys should be constructed. A toy is represented with a positive integer, according to its size. More precisely: if when opening the toy represented by m we find the toys represented by n 1 , n 2 , …, n r , it must be true that n 1 +n 2 +…+n r < m. And if this is the case, we say that toy m contains directly the toys n 1 , n 2 , …, n r . It should be clear that toys that may be contained in any of the toys n 1 , n 2 , …, n r are not considered as directly contained in the toy m.
A generalized matrioshka is denoted with a non-empty sequence of non zero integers of the form:
a 1 a 2 … a N
such that toy k is represented in the sequence with two integers −k and k, with the negative one occurring in the sequence first that the positive one.
For example, the sequence
−9 − 7 − 2 2 − 3 − 2 − 1 1 2 3 7 9
represents a generalized matrioshka conformed by six toys, namely, 1, 2 (twice), 3, 7 and 9. Note that toy 7 contains directly toys 2 and 3. Note that the first copy of toy 2 occurs left from the second one and that the second copy contains directly a toy 1. It would be wrong to understand that the first −2 and the last 2 should be paired.
On the other hand, the following sequences do not describe generalized matrioshkas:

−9 − 7 − 2 2 − 3 − 1 − 2 2 1 3 7 9
because toy 2 is bigger than toy 1 and cannot be allocated inside it.

−9 − 7 − 2 2 − 3 − 2 − 1 1 2 3 7 − 2 2 9
because 7 and 2 may not be allocated together inside 9.

−9 − 7 − 2 2 − 3 − 1 − 2 3 2 1 7 9
because there is a nesting problem within toy 3.
Your problem is to write a program to help Vladimir telling good designs from bad ones.

Input
The input file contains several test cases, each one of them in a separate line. Each test case is a
sequence of non zero integers, each one with an absolute value less than 10 7 .

Output
Output texts for each input case are presented in the same order that input is read.
For each test case the answer must be a line of the form
:-) Matrioshka!
if the design describes a generalized matrioshka. In other case, the answer should be of the form
:-( Try again.

Sample Input
-9 -7 -2 2 -3 -2 -1 1 2 3 7 9
-9 -7 -2 2 -3 -1 -2 2 1 3 7 9
-9 -7 -2 2 -3 -1 -2 3 2 1 7 9
-100 -50 -6 6 50 100
-100 -50 -6 6 45 100
-10 -5 -2 2 5 -4 -3 3 4 10
-9 -5 -2 2 5 -4 -3 3 4 9
Sample Output
:-) Matrioshka!
:-( Try again.
:-( Try again.
:-) Matrioshka!
:-( Try again.
:-) Matrioshka!
:-( Try again.

中文:

给你一堆套娃序列,问你能否都套在一起?一个套娃中可以装多个套娃,也可以装一个套娃,如果装多个套娃那么这些套娃的体积和要小于大的套娃。
套娃中包含其他套娃的方式类似于括号,例如体积大小为10的套娃,-10….10表示在10之间有其它内容。

#include <bits/stdc++.h>

using namespace std;

typedef long long ll;
string s,tmp;
vector<int> vi;

int main()
{

    ios::sync_with_stdio(false);
    while(getline(cin,s))
    {
        if(s[0]=='\0')
            continue;

        vi.clear();

        stringstream ss(s);

        stack<int> spac,num;

        while(ss>>tmp)
            vi.push_back(stoi(tmp));

        if(vi.size()%2)
        {
            cout<<":-( Try again."<<endl;
            continue;
        }

        int flag=0;
        for(int i=0;i<vi.size();i++)
        {

            if(vi[i]<0)
            {
                if(!num.empty())
                {
                    if(spac.top()<=abs(vi[i]))
                    {
                        flag=1;
                        break;
                    }
                    int res=spac.top()-abs(vi[i]);
                    spac.pop();
                    spac.push(res);
                }
                spac.push(abs(vi[i]));
                num.push(vi[i]);
            }
            else
            {
                if(num.empty()||-num.top()!=vi[i])
                {
                    flag=1;
                    break;
                }
                spac.pop();
                num.pop();
            }

        }
        if(flag==1)
            cout<<":-( Try again."<<endl;
        else
            cout<<":-) Matrioshka!"<<endl;

    }
    return 0;
}


解答:

最开始设计的想法弄错了,按照每一层的体积去累加套娃的体积。但是忽略了一个重要问题,就是每一层可能有多个套娃,不能这样计算。

正确的思路是建立两个栈,分别用来保存当前的剩余空间和当前的匹配状态即可。

猜你喜欢

转载自blog.csdn.net/tengfei461807914/article/details/81867495