PAT--1064 Complete Binary Search Tree (30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

 代码:

#include <iostream>
#include <bits/stdc++.h>
using namespace std;
int flag = 0;
int n;
int b[1010];
void inOrder(int root,int a[]){
    if(root>n) return;
    inOrder(root*2,a);
    b[root] = a[flag++];
    inOrder(root*2+1,a);
}
int main()
{
    cin>>n;
    int a[n+1];
    for(int i=0; i<n; i++)
    {
        cin>>a[i];
    }
    sort(a,a+n);
   inOrder(1,a);


    for(int i=1; i<=n; i++)
    {
        if(i==1){
            cout<<b[i];
        }else{
            cout<<" "<<b[i];
        }

    }
    cout<<endl;
    return 0;
}

分析:

首先完全二叉树的编号规律:第i个节点的左孩子编号为2*i,右孩子编号为2*i+1,且最左下角的节点一定是值最小的结点。

 把输入的结点从小到大排好序后,(以节点8为例),则一直递归到最左下的结点即为a[0];

猜你喜欢

转载自blog.csdn.net/jackson_j/article/details/98476749