hdu1023 Train Problem II 卡特兰数

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/tju_peter/article/details/55190496

Train Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9002    Accepted Submission(s): 4817


Problem Description
As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.
 

Input
The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.
 

Output
For each test case, you should output how many ways that all the trains can get out of the railway.
 

Sample Input
 
  
1 2 3 10
 

Sample Output
 
  
1 2 5 16796
Hint
The result will be very large, so you may not process it by 32-bit integers.
 

Author
Ignatius.L
 

Recommend
 火车进站的出战顺序,经典卡特兰数模型,此题需要大数,看了别人写的代码次啊学会了实现方法,之前想到了这么写但是没有是实现,自己代码能力真的很差。。。。。
#include <iostream>
#include <cstring>
#include <iomanip>
#define base 10000
#define mlen 120

using namespace std;

int cat[mlen][mlen];

int mul(int a[],int n)
{
    int carry=0;
    for(int i=0;i<mlen;i++)
    {
        carry=carry+a[i]*n;
        a[i]=carry%base;
        carry=carry/base;
    }
}

int div(int a[],int n)
{
    int bak=0;
    for(int i=mlen-1;i>=0;i--)
    {
        bak=bak*base+a[i];
        a[i]=bak/n;
        bak=bak%n;
    }
}

int catalan()
{
    memset(cat,0,sizeof(cat));
    cat[0][0]=1;
    cat[1][0]=1;
    for(int i=2;i<mlen;i++)
    {
        memcpy(cat[i],cat[i-1],sizeof(cat[i-1]));
        mul(cat[i],4*i-2);
        div(cat[i],i+1);
    }
}
int main()
{
    int t;
    catalan();
    while(cin>>t)
    {
        int i=mlen-1;
        while(cat[t][i]==0)
                i--;
        cout<<cat[t][i];
        i--;
        for(;i>=0;i--)
            cout<<setfill('0')<<setw(4)<<cat[t][i];
        cout<<endl;
    }
    return 0;
}
iomanip头文件里面,setw()设置输出几位,如果不用setfill(char )的话 会用空格补位  用了setfill(char)补位会用指定的char。

 
  

猜你喜欢

转载自blog.csdn.net/tju_peter/article/details/55190496
今日推荐