The The Circumference of the Circle

题目描述

To calculate the circumference of a circle seems to be an easy task - provided you know its diameter. But what if you don't? 

You are given the cartesian coordinates of three non-collinear points in the plane. 
Your job is to calculate the circumference of the unique circle that intersects all three points. 

输入

The input will contain one or more test cases. Each test case consists of one line containing six real numbers x1,y1, x2,y2,x3,y3, representing the coordinates of the three points. The diameter of the circle determined by the three points will never exceed a million. Input is terminated by end of file.

输出

For each test case, print one line containing one real number telling the circumference of the circle determined by the three points. The circumference is to be printed accurately rounded to two decimals. The value of pi is approximately 3.141592653589793.

样例输入

0.0 -0.5 0.5 0.0 0.0 0.5
0.0 0.0 0.0 1.0 1.0 1.0
5.0 5.0 5.0 7.0 4.0 6.0
0.0 0.0 -1.0 7.0 7.0 7.0
50.0 50.0 50.0 70.0 40.0 60.0
0.0 0.0 10.0 0.0 20.0 1.0
0.0 -500000.0 500000.0 0.0 0.0 500000.0

样例输出

3.14
4.44
6.28
31.42
62.83
632.24
3141592.65
题目大意:已知三角形的三个顶点坐标,求其外接圆的周长。

解法:刚看到这道题时,马上拿出草稿纸画图,想推导出重心坐标,然后求出半径,再求周长。可是这个过程太复杂了,写到一半就没有兴致了,还是求助于Google。在Wiki百科找到一个已知三条边长度,求外接三角形周长的算法,diameter = abc/2*(sqrt(s(s-a)(s-b)(s-c)),s=(a+b+c)/2。问题瞬间简化了,求两点距离是很方便的一件事,然后套用这个公式就可以了。

#include<iostream>
#include<iomanip>
#include<cmath>
#define PI 3.141592653589793
using namespace std;

double distance(double x1,double y1,double x2,double y2);

int main(){
	double x1,x2,x3,y1,y2,y3;
	double C,d,xx,yy,a,b,c;

	while(cin>>x1>>y1>>x2>>y2>>x3>>y3){
		a=distance(x1,y1,x2,y2);
		b=distance(x2,y2,x3,y3);
		c=distance(x3,y3,x1,y1);
		d=2*a*b*c/(sqrt((a+b+c)*(-a+b+c)*(a-b+c)*(a+b-c)));
		C=d*PI;
		cout<< fixed << setprecision(2) <<C<<endl;
	}
	return 0;
}

double distance(double x1,double y1,double x2,double y2){
	return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}

猜你喜欢

转载自blog.csdn.net/A_I_Q/article/details/82185894