程序设计基础5 栈的题目

PAT 1051

1051 Pop Sequence(25 分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

一,以前解法

#include<cstdio>
#include<stack>
using namespace std;
//到14:45
stack<int> st;
int arr[1010];
int main() {
	int m = 0;
	int n = 0;
	int k = 0;
	scanf("%d %d %d", &m, &n, &k);
	while (k--) {
		while (!st.empty()) {
			st.pop();
		}
		int count = 0;
		int flag = 0;
		int max = 0;
		for (int i = 0; i < n; i++) {
			scanf("%d", &arr[i]);
		}
		for (int i = 0; i < n; i++) {
			if (!st.empty()&&arr[i] > st.top()) {
				for (int j = max + 1; j <= arr[i]; j++) {
					st.push(j);
					if (arr[i] > max) {
						max = arr[i];
					}
					if (count > 5) {
						flag = 1;
						break;
					}
				}
			}
			if (st.empty()) {
				for (int j = max+1; j <= arr[i]; j++) {
					st.push(j);
					count++;
					if (arr[i] > max) {
						max = arr[i];
					}
					if (count > 5) {
						flag = 1;
						break;
					}
				}
			}
			if (arr[i] == st.top()) {
				st.pop();
				count--;
			}
			else {
				flag = 1;
				break;
			}

		}
		if (flag == 0&&st.empty()) {
			printf("YES\n");
		}
		else {
			printf("NO\n");
		}
	}
	return 0;
}

二,如今解法

#include<cstdio>
#include<stack>
using namespace std;
//到14:45
stack<int> st;
int arr[1010];
int main() {
	int m = 0;
	int n = 0;
	int k = 0;
	int flag = 1;
	scanf("%d %d %d", &m, &n, &k);
	for (int i = 0; i < k; i++) {
		while (!st.empty()) {
			st.pop();
		}
		for (int j = 0; j < n; j++) {
			scanf("%d", &arr[j]);
		}
		int current = 0;
		for (int i = 1; i <= n; i++) {
			st.push(i);
			if (st.size() > m) {
				break;
				flag = 0;
			}
			while (!st.empty() && st.top() == arr[current]) {
				st.pop();
				current++;
			}
		}
		if (flag == 1 && st.empty()) {
			printf("YES\n");
		}
		else {
			printf("NO\n");
		}
	}
	return 0;
}

三,总结

以前解法是对要检验的数组的每个值进行遍历,然后对栈进行相应的处理,有不合格的直接退出。栈的增加要以目前的数组扫描到的为界限,会引发一系列问题,例如栈提前空了怎么办,当前扫描的值与栈顶元素大小的比较等。

正确解法是以顺序插入为驱动,与当前扫描的值一致的时候pop,然后自动扫描下一个,不一致继续顺序插入,没有前一种解法的冗余。

四,Note

要在pop()和top()操作前判空。

猜你喜欢

转载自blog.csdn.net/qq2285580599/article/details/82148757