hdu 1536 S-Nim SG函数 模板

版权声明:本博客内容基本为原创,如有问题欢迎联系,未经允许请勿转载 https://blog.csdn.net/qq_41955236/article/details/82146552

S-Nim

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10028    Accepted Submission(s): 4110


 

Problem Description

Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:


  The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.

  The players take turns chosing a heap and removing a positive number of beads from it.

  The first player not able to make a move, loses.


Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:


  Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).

  If the xor-sum is 0, too bad, you will lose.

  Otherwise, move such that the xor-sum becomes 0. This is always possible.


It is quite easy to convince oneself that this works. Consider these facts:

  The player that takes the last bead wins.

  After the winning player's last move the xor-sum will be 0.

  The xor-sum will change after every move.


Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win.

Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?

your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.

 

Input

Input consists of a number of test cases. For each test case: The first line contains a number k (0 < k ≤ 100 describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. The last test case is followed by a 0 on a line of its own.

 

Output

For each position: If the described position is a winning position print a 'W'.If the described position is a losing position print an 'L'. Print a newline after each test case.

 

Sample Input

 

2 2 5

3

2 5 12

3 2 4 7

4 2 3 7 12

5 1 2 3 4 5

3

2 5 12

3 2 4 7

4 2 3 7 12

0

 

Sample Output

 

LWW

WWL


题意:

    取石子游戏。给你一个集合,集合里有n个数,每次你只能从一个堆里取这个集合里的数那么多的石子,谁先不能取谁就输。给你q个询问,每个询问里有m个堆,再给你每个堆里有多少个石子。

做法:

     第一次接触sg函数.sg函数就是一个状态,如果sg[i]不为0,那么就是必胜态,如果为0就是必败态。

     sg函数做题目其实就是通过暴力打表,从数量少的状态开始往大的枚举,把数量多的状态从小的状态转化过来,如果你取完之后(即代码中的i-s[j])是必胜态(即代码中的sg不为0),那么你就有可能是必败态,假设有一种取法可以让你成为必胜态(即取完之后的sg[i-s[j]]为0),那么0就会被覆盖,在之后取mex的时候就不会再取0。

      mex就是未在集合中的最小非负整数 , 例如mex{1}=0 , mex{0,2}=1 , mex{}=0。


#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn=10005;
int sg[maxn],a[105],m,n;
bool vis[maxn];
void sg_init(int s[],int len){
    memset(sg,0,sizeof(sg));
    for(int i=1;i<maxn;i++){
        memset(vis,0,sizeof(vis));
        for(int j=1;j<=len&&s[j]<=i;j++){
            vis[sg[i-s[j]]]=1;
        }
        for(int j=0;j<maxn;j++){
            if(!vis[j]){
                sg[i]=j;
                break;
            }
        }
    }
}
int main(){
    while(~scanf("%d",&n)){
        if(n==0) break;
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        sort(a+1,a+1+n);
        sg_init(a,n);
        scanf("%d",&m);
        while(m--){
            int num,x,ans=0;
            scanf("%d",&num);
            while(num--){
                scanf("%d",&x);
                ans^=sg[x];
            }
            if(ans) printf("W");
            else printf("L");
        }
        cout<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41955236/article/details/82146552