POJ 2960 S-Nim(sg函数)

Description

Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:
  • The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.
  • The players take turns chosing a heap and removing a positive number of beads from it.
  • The first player not able to make a move, loses.
Arthur and Caroll really enjoyed playing this simple game until they 
recently learned an easy way to always be able to find the best move:
  • Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).
  • If the xor-sum is 0, too bad, you will lose.
  • Otherwise, move such that the xor-sum becomes 0. This is always possible.
It is quite easy to convince oneself that this works. Consider these facts:
  • The player that takes the last bead wins.
  • After the winning player's last move the xor-sum will be 0.
  • The xor-sum will change after every move.
Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win. 

Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S = {2, 5} each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it? 

your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.

Input

Input consists of a number of test cases. 
For each test case: The first line contains a number k (0 < k ≤ 100) describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. 
The last test case is followed by a 0 on a line of its own.

Output

For each position: If the described position is a winning position print a 'W'.If the described position is a losing position print an 'L'. 
Print a newline after each test case.

Sample Input

2 2 5
3
2 5 12
3 2 4 7
4 2 3 7 12
5 1 2 3 4 5
3
2 5 12
3 2 4 7
4 2 3 7 12
0

Sample Output

LWW
WWL

题意:

n堆石子,每个玩家现在只允许在,预定义的集合S中移除指定数量的石子。

取完石头者胜。


思路:

用记忆化搜索,或者枚举的方法,得到sg函数值,求单个游戏sg值的nim和,即为整个游戏的sg值。

注意标记数组开成105,因为最多只有100种取法,那么sg值不会超过100。如果开成10000,速度大打折扣


代码:

枚举+预处理 90+ms

#include<stdio.h>
#include<string.h>

#define For(a,b,c) for(int a = b; a <= c; a++)
#define ll long long
#define mem(a,b) memset(a,b,sizeof(a))

int f[105], sg[10005], book[105];

void get_sg(int limit)
{
    for(int i = 0; i < 10001; i++)
    {
        mem(book,0);
        For(j,1,limit)
        {
            int k = i - f[j];
            if(k < 0) continue;
            book[sg[k]] = 1;
        }
        for(int j = 0; ;j++)
        {
            if(!book[j])
            {
                sg[i] = j;
                break;
            }
        }
    }
}

int main()
{
    int limit;
    while(scanf("%d",&limit), limit)
    {
        For(i,1,limit) scanf("%d",&f[i]);
        get_sg(limit);
        int t;
        scanf("%d",&t);
        while(t--)
        {
            int n;
            scanf("%d",&n);
            int ans = 0, a;
            while(n--)
            {
                scanf("%d",&a);
                ans ^= sg[a];
            }
            printf("%c", ans ? 'W' : 'L');
        }
        printf("\n");
    }
    return 0;
}

dfs 90+ms

#include<stdio.h>
#include<string.h>

#define For(a,b,c) for(int a = b; a <= c; a++)
#define ll long long
#define mem(a,b) memset(a,b,sizeof(a))

int f[105], sg[10005];
int limit;

void get_sg(int a)
{
    if(sg[a] != -1) return;
    bool book[105];
    mem(book,false);
    For(i,1,limit)
    {
        int k = a - f[i];
        if(k < 0) continue;
        if(sg[k] == -1) get_sg(k);
        book[sg[k]] = 1;
    }
    for(int i = 0; ; i++) if(!book[i]) {sg[a] = i; return;}
}

int main()
{
    while(scanf("%d",&limit), limit)
    {
        For(i,1,limit) scanf("%d",&f[i]);
        mem(sg,-1);
        sg[0] = 0;

        int t;
        scanf("%d",&t);
        while(t--)
        {
            int n;
            scanf("%d",&n);
            int ans = 0, a;
            while(n--)
            {
                scanf("%d",&a);
                if(sg[a] == -1) get_sg(a);
                ans ^= sg[a];
            }
            printf("%c", ans ? 'W' : 'L');
        }
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/j2_o2/article/details/80388053