ZOJ 2850:Beautiful Meadow

Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu 


Tom's Meadow

Tom has a meadow in his garden. He divides it into N * M squares. Initially all the squares were covered with grass. He mowed down the grass on some of the squares and thinks the meadow is beautiful if and only if

  1. Not all squares are covered with grass.
  2. No two mowed squares are adjacent.

Two squares are adjacent if they share an edge. Here comes the problem: Is Tom's meadow beautiful now?

Input

The input contains multiple test cases!

Each test case starts with a line containing two integers NM (1 <= NM <= 10) separated by a space. There follows the description of Tom's Meadow. There're N lines each consisting of Mintegers separated by a space. 0(zero) means the corresponding position of the meadow is mowed and 1(one) means the square is covered by grass.

A line with N = 0 and M = 0 signals the end of the input, which should not be processed

Output

One line for each test case.

Output "Yes" (without quotations) if the meadow is beautiful, otherwise "No"(without quotations).

Sample Input

2 2
1 0
0 1
2 2
1 1
0 0
2 3
1 1 1
1 1 1
0 0

Sample Output

Yes
No
No

题解:0代表被割,1代表有草,adjacent邻,mowed割。漂亮草地的条件:1不是所有方块都是草;2被割的不相邻。告诉自己以后输出跟操作还是分开写比较好......

代码:

#include <iostream>
using namespace std;
int a[15][15];
int main()
{
    int n,m;
    while(cin>>n>>m)
    {
        if(n==0&&m==0)
            break;
        int cnt=0;
        int flag=0;
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<m; j++)
            {
                cin>>a[i][j];
            }
        }
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<m; j++)
            {

                if(a[i][j]==1)
                    cnt++;
                if(cnt==n*m)
                    flag=1;
                if(a[i][j]==0)
                {
                    if((j+1)<m&&a[i][j+1]==0)
                        flag=1;
                    else if(i-1>=0&&a[i-1][j]==0)
                        flag=1;
                    else if(j-1>=0&&a[i][j-1]==0)
                        flag=1;
                    else if(i+1<n&&a[i+1][j]==0)
                        flag=1;
                }

            }
        }
        //cout<<"cnt"<<cnt<<endl;
        //cout<<"flag"<<flag<<endl;
        if(flag==0)
            cout<<"Yes"<<endl;
        else
            cout<<"No"<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42671353/article/details/81876860
ZOJ
今日推荐