HDU 6308(模拟)

Time Zone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 607    Accepted Submission(s): 204


 

Problem Description

Chiaki often participates in international competitive programming contests. The time zone becomes a big problem.
Given a time in Beijing time (UTC +8), Chiaki would like to know the time in another time zone s.

 

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains two integers a, b (0≤a≤23,0≤b≤59) and a string s in the format of "UTC+X'', "UTC-X'', "UTC+X.Y'', or "UTC-X.Y'' (0≤X,X.Y≤14,0≤Y≤9).

 

Output

For each test, output the time in the format of hh:mm (24-hour clock).

 

Sample Input

 

3 11 11 UTC+8 11 12 UTC+9 11 23 UTC+0

 

Sample Output

 

11:11 12:12 03:23

 

Source

2018 Multi-University Training Contest 1

 

根据题意模拟即可。

#include<cstdio>
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        int a,b;
        scanf("%d%d",&a,&b);
        char s[100];
        scanf("%s",s);
        int x=0,y=0,i=4;
        for(;s[i]!='\0';i++){
            if(s[i]=='.') break;
            x=x*10+s[i]-'0';
        }
        if(s[i]!='\0'){
            i++;
            for(;s[i]!='\0';i++){
                y=y*10+s[i]-'0';
            }
        }
        if(s[3]=='-'){
            x=-x;
            y=-y;
        }
        x-=8;
        b+=y*6;
        while(b>=60){
            a+=1;
            b-=60;
        }
        while(b<0){
            a-=1;
            b+=60;
        }
        a+=x;
        while(a>23){
            a-=24;
        }
        while(a<0){
            a+=24;
        }
        printf("%02d:%02d\n",a,b);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wyj_alone_smile/article/details/81177130
今日推荐