Poj 1704 Georgia and Bob

版权声明:转载请说明出处 https://blog.csdn.net/bao___zi/article/details/81612105

Description

Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example:


Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game.

Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out.

Given the initial positions of the n chessmen, can you predict who will finally win the game?

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.

Output

For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise 'Not sure'.

Sample Input

2
3
1 2 3
8
1 5 6 7 9 12 14 17

Sample Output

Bob will win
Georgia will win

题意:给你n个棋子所在的位置,有两个人轮流选择其中一个棋子往右边移动至少一个位置,不能越过其他棋子。当有人不能操作的时候,他就输了。问你给你的状态是必赢还是必输?

解题思路:我们把棋子按位置升序排列后,从后往前把他们两两绑定成一对。如果总个数是奇数,就把最前面一个和边界(位置为0)绑定。 在同一对棋子中,如果对手移动前一个,你总能对后一个移动相同的步数,所以一对棋子的前一个和前一对棋子的后一个之间有多少个空位置对最终的结果是没有影响的。于是我们只需要考虑同一对的两个棋子之间有多少空位。我们把每一对两颗棋子的距离(空位数)视作一堆石子,在对手移动每对两颗棋子中靠右的那一颗时,移动几位就相当于取几个石子,与取石子游戏对应上了,各堆的石子取尽,就相当再也不能移动棋子了。

/*************************************************************************
	> File Name: poj1704.cpp
	> Author: baozi
	> Last modified: 2018年08月12日 星期日 22时31分
	> status:AC 
 ************************************************************************/
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn=1e4+10;
int t,n,num[maxn];
int main(){
	int i,j;
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		for(i=1;i<=n;i++){
			scanf("%d",&num[i]);
		}
		sort(num+1,num+1+n);
		int ans=0;
		for(i=n;i>0;i-=2){
			int t=num[i]-num[i-1]-1;
			ans^=t;
		}
		if(ans) printf("Georgia will win\n");
		else printf("Bob will win\n"); 
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/bao___zi/article/details/81612105
BOB
今日推荐