K - Lweb and String

Lweb has a string SS. 

Oneday, he decided to transform this string to a new sequence. 

You need help him determine this transformation to get a sequence which has the longest LIS(Strictly Increasing). 

You need transform every letter in this string to a new number. 

AA is the set of letters of SS, BB is the set of natural numbers. 

Every injection f:A→Bf:A→B can be treat as an legal transformation. 

For example, a String “aabc”, A={a,b,c}A={a,b,c}, and you can transform it to “1 1 2 3”, and the LIS of the new sequence is 3. 

Now help Lweb, find the longest LIS which you can obtain from SS. 

LIS: Longest Increasing Subsequence. (https://en.wikipedia.org/wiki/Longest_increasing_subsequence)

Input

The first line of the input contains the only integer T,(1≤T≤20)T,(1≤T≤20). 

Then TT lines follow, the i-th line contains a string SS only containing the lowercase letters, the length of SS will not exceed 105105.

Output

For each test case, output a single line "Case #x: y", where x is the case number, starting from 1. And y is the answer.

Sample Input

2
aabcc
acdeaa

Sample Output

Case #1: 3
Case #2: 4
#include <iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int main()
{
    int t;
    cin>>t;
    int p=0;
    while(t--)
    {
        string s;
        cin>>s;
        int sum=0;
        int n=s.size();
        int i;
        int a[100010];
        memset(a,0,sizeof(a));
        for(i=0; i<n; i++)
        {
            int x=s[i]-'0';
            if(a[x]==0)
            {a[x]=1;
                sum++;
            }
        }
        p++;
        printf("Case #%d: %d\n",p,sum);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41374539/article/details/81950544