PTA:K times in the string (10分)(C语言)

Given a positive integer K and a string (consisting of no more than 100 numbers and letters), you need to find out the first character that appears at least K times.

If such a character does not exist, output No solution .

Sample Input 1:
3 coincidance

Sample Output 1:
c

Sample Input 2:
5 pineapple

Sample Output 2:
No solution

#include <stdio.h>

int main()
{
    char str1[127] = {0};
    char str2[100];
    int k;
    int judge = 0;
    scanf("%d", &k);
    scanf("%s", &str2);
    int i, j;
    for (i = 0; str2[i] != '\0'; i++)
    {
        j = str2[i];
        str1[j]++;
    }
    for (j = 0; j <= 127; j++)
    {
        if(str1[j] == k)
        {
            printf("%c", j);
            judge = 1;
        }

    }
    if (judge == 0)
        printf("No solution");

    return 0;
}
发布了58 篇原创文章 · 获赞 21 · 访问量 604

猜你喜欢

转载自blog.csdn.net/qq_45624989/article/details/105399594