A Possible Tree(带权并查集+向量偏移)

                                     A Possible Tree

                                                        时间限制: 2 Sec  内存限制: 128 MB
                                                                   提交: 133  解决: 42
                                                          [提交] [状态] [讨论版] [命题人:admin]

题目描述

Alice knows that Bob has a secret tree (in terms of graph theory) with n nodes with n − 1 weighted edges with integer values in [0, 260 −1]. She knows its structure but does not know the specific information about edge weights.
Thanks to the awakening of Bob’s conscience, Alice gets m conclusions related to his tree. Each conclusion provides three integers u, v and val saying that the exclusive OR (XOR) sum of edge weights in the unique shortest path between u and v is equal to val.
Some conclusions provided might be wrong and Alice wants to find the maximum number W such that the first W given conclusions are compatible. That is say that at least one allocation of edge weights satisfies the first W conclusions all together but no way satisfies all the first W + 1 conclusions (or there are only W conclusions provided in total).
Help Alice find the exact value of W.

输入

The input has several test cases and the first line contains an integer t (1 ≤ t ≤ 30) which is the number of test cases.
For each case, the first line contains two integers n (1 ≤ n ≤ 100000) and c (1 ≤ c ≤ 100000) which are the number of nodes in the tree and the number of conclusions provided. Each of the following n−1 lines contains two integers u and v (1 ≤ u, v ≤ n) indicating an edge in the tree between the u-th node and the v-th node. Each of the following c lines provides a conclusion with three integers u, v and val where 1 ≤ u, v ≤ n and val ∈ [0, 260 − 1].

输出

For each test case, output the integer W in a single line.

样例输入

2
7 5
1 2
2 3
3 4
4 5
5 6
6 7
1 3 1
3 5 0
5 7 1
1 7 1
2 3 2
7 5
1 2
1 3
1 4
3 5
3 6
3 7
2 6 6
4 7 7
6 7 3
5 4 5
2 5 6

样例输出

3
4

                                                                               [提交] [状态]

#include<bits/stdc++.h>
#define ll long long
int n,c;
int u,v;
ll val;
ll value[200005];
int f[200005];
int find(int x)
{
    if(x==f[x])
        return x;
    int fx=f[x];
    f[x]=find(f[x]);
    value[x]^=value[fx];
    return f[x];
}
int join(int u,int v,ll val)
{
    int fx=find(u);
    int fy=find(v);
    if(fx==fy)return 0;
    value[fx]^=value[u]^value[v]^val;
    f[fx]=fy;
    return 1;
}
int main()
{
    int t;
    scanf("%d",&t);

    while(t--)
    {
        scanf("%d%d",&n,&c);
        for(int i=1;i<n;i++)scanf("%d%d",&u,&v);

        for(int i=1;i<=n;i++)f[i]=i,value[i]=0;

        int flag=0;
        int ans;
        for(int i=1;i<=c;i++)
        {
            scanf("%d%d%lld",&u,&v,&val);
            if(!flag && !join(u,v,val) && (value[u]^value[v])!=val)
            {
                ans=i-1;
                flag=1;
            }
        }
        printf("%d\n",ans);

    }
}

猜你喜欢

转载自blog.csdn.net/qq_41021816/article/details/81988242
今日推荐