【HDU 1068】Girls and Boys 二分图最大独立集合+匈牙利算法

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Xylon_/article/details/82151959

                                      Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13764    Accepted Submission(s): 6469


 

Problem Description

the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.

 

Sample Input

7

0: (3) 4 5 6

1: (2) 4 6

2: (0)

3: (0)

4: (2) 0 1

5: (1) 0

6: (2) 0 1

3

0: (2) 1 2

1: (1) 0

2: (1) 0

Sample Output

5 2

题意:有n个人,每个人认识一些其他人,找出一个最大集合,集合中的每个人都互相不认识。

新模板get√

推荐阅读:趣写算法系列之--匈牙利算法

代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<cstdio>
using namespace std;
#define ll long long
#define inf 0x3f3f3f3f
#define mem(a,b) memset(a,b,sizeof(a))
#define closeio std::ios::sync_with_stdio(false)
#define maxn 505

int map[maxn][maxn],vis[maxn],pre[maxn],n;

bool find(int x)
{
	int i;
	for(i=0;i<n;i++)
	{
		if(map[x][i]==1&&!vis[i])
		{
			vis[i]=1;
			if(pre[i]==-1||find(pre[i]))
			{
				pre[i]=x;
				return 1;
			}
		}
	}
	return 0;
}

int main()
{
	int m,a,b,i,j,ans;
	while(~scanf("%d",&n))
	{
		mem(map,0);
		mem(pre,-1);
		for(i=0;i<n;i++)
		{
			scanf("%d: (%d)",&a,&m);
			for(j=0;j<m;j++)
			{
				scanf("%d",&b);
				map[a][b]=1;
			}
		}
		ans=0;
		for(i=0;i<n;i++)
		{
			mem(vis,0);
			ans+=find(i);
		}
		printf("%d\n",n-ans/2);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Xylon_/article/details/82151959
今日推荐