HDU1355 The Peanuts(模拟)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/BBHHTT/article/details/82108955

The Peanuts

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 908    Accepted Submission(s): 537

Problem Description

Mr. Robinson and his pet monkey Dodo love peanuts very much. One day while they were having a walk on a country road, Dodo found a sign by the road, pasted with a small piece of paper, saying "Free Peanuts Here! " You can imagine how happy Mr. Robinson and Dodo were. 

There was a peanut field on one side of the road. The peanuts were planted on the intersecting points of a grid as shown in Figure-1. At each point, there are either zero or more peanuts. For example, in Figure-2, only four points have more than zero peanuts, and the numbers are 15, 13, 9 and 7 respectively. One could only walk from an intersection point to one of the four adjacent points, taking one unit of time. It also takes one unit of time to do one of the following: to walk from the road to the field, to walk from the field to the road, or pick peanuts on a point. 



According to Mr. Robinson's requirement, Dodo should go to the plant with the most peanuts first. After picking them, he should then go to the next plant with the most peanuts, and so on. Mr. Robinson was not so patient as to wait for Dodo to pick all the peanuts and he asked Dodo to return to the road in a certain period of time. For example, Dodo could pick 37 peanuts within 21 units of time in the situation given in Figure-2. 

Your task is, given the distribution of the peanuts and a certain period of time, tell how many peanuts Dodo could pick. You can assume that each point contains a different amount of peanuts, except 0, which may appear more than once.

Input

The first line of input contains the test case number T (1 <= T <= 20). For each test case, the first line contains three integers, M, N and K (1 <= M, N <= 50, 0 <= K <= 20000). Each of the following M lines contain N integers. None of the integers will exceed 3000. (M * N) describes the peanut field. The j-th integer X in the i-th line means there are X peanuts on the point (i, j). K means Dodo must return to the road in K units of time.

Output

For each test case, print one line containing the amount of peanuts Dodo can pick.

Sample Input

2

6 7 21

0 0 0 0 0 0 0

0 0 0 0 13 0 0

0 0 0 0 0 0 7

0 15 0 0 0 0 0

0 0 0 9 0 0 0

0 0 0 0 0 0 0

6 7 20

0 0 0 0 0 0 0

0 0 0 0 13 0 0

0 0 0 0 0 0 7

0 15 0 0 0 0 0

0 0 0 9 0 0 0

0 0 0 0 0 0 0

Sample Output

37

28

 思路:HDU分类分在了dp,其实就是模拟,把花生数量从大到小排序,模拟拿的过程就可以了,不过刚开始把输出写在break的前一行,找了一个多小时的错误,输出要写在循环外。

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node{
	int x,y,num;
}mat[2550];
int cmp(node a,node b) {
	return a.num>b.num;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--) {
		int n,m,time,g,k=0;
		scanf("%d%d%d",&m,&n,&time);
		for(int i=0;i<m;i++) {
			for(int j=0;j<n;j++) {
				scanf("%d",&g);
				if(g) {
					mat[k].num=g;
					mat[k].x=i;
					mat[k].y=j;
					k++;
				}
			}
		}
		time-=2;
		int ti1=0;//到达并采摘的时间 
		int ti2=0;//当前点返回的时间 
		int sum=0;//总的花生数量 
		sort(mat,mat+k,cmp);
		for(int i=0;i<k;i++) {
			if(i==0){
				ti1=mat[i].x+1;
				ti2=mat[i].x;
			}
			else {
				ti1=(fabs(mat[i].x-mat[i-1].x)+fabs(mat[i].y-mat[i-1].y)+1);
				ti2=mat[i].x;
			}
			if((time-ti1-ti2)>=0)
			{//当前的能采摘 
				sum+=mat[i].num;
				time-=ti1;//之前去到达的时间,看下一个能采摘不 
			}
			else 	break;
		}
		printf("%d\n",sum);//输出写在for外
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/BBHHTT/article/details/82108955